summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-23 09:23:52 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-23 10:15:50 +0100
commit25f6812f11452d93b11fc18daaa66bcca3213b54 (patch)
tree043a42f120443610007faf60983d86699d6a7337 /dev-ros/rosclean/rosclean-1.14.0.ebuild
parentdev-ros/rosboost_cfg: Bump to 1.14.0. (diff)
downloadgentoo-25f6812f11452d93b11fc18daaa66bcca3213b54.tar.gz
gentoo-25f6812f11452d93b11fc18daaa66bcca3213b54.tar.bz2
gentoo-25f6812f11452d93b11fc18daaa66bcca3213b54.zip
dev-ros/rosclean: Bump to 1.14.0.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rosclean/rosclean-1.14.0.ebuild')
-rw-r--r--dev-ros/rosclean/rosclean-1.14.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosclean/rosclean-1.14.0.ebuild b/dev-ros/rosclean/rosclean-1.14.0.ebuild
new file mode 100644
index 000000000000..3bdb71d90d48
--- /dev/null
+++ b/dev-ros/rosclean/rosclean-1.14.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Cleanup filesystem resources (e.g. log files)"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+PATCHES=( "${FILESDIR}/bb.patch" )