summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-05-07 11:52:58 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-05-07 12:00:21 +0200
commit9e468bdc46f7c11fb75e16b81c4fa1fd3be0f6f6 (patch)
treea8b8c1afece8824c81806c2c101239c0371d0728 /dev-ros/rosmake/rosmake-1.14.6.ebuild
parentdev-ros/roscreate: Bump to 1.14.6. (diff)
downloadgentoo-9e468bdc46f7c11fb75e16b81c4fa1fd3be0f6f6.tar.gz
gentoo-9e468bdc46f7c11fb75e16b81c4fa1fd3be0f6f6.tar.bz2
gentoo-9e468bdc46f7c11fb75e16b81c4fa1fd3be0f6f6.zip
dev-ros/rosmake: Bump to 1.14.6.
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosmake/rosmake-1.14.6.ebuild')
-rw-r--r--dev-ros/rosmake/rosmake-1.14.6.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/rosmake/rosmake-1.14.6.ebuild b/dev-ros/rosmake/rosmake-1.14.6.ebuild
new file mode 100644
index 000000000000..734dd611a6f8
--- /dev/null
+++ b/dev-ros/rosmake/rosmake-1.14.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_5} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS dependency aware build tool"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"