summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-05 12:53:16 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-05 12:58:32 +0100
commit6121fc2130eb7280b4171935f1eb0ae2f2046f88 (patch)
treefb4c18079548a8ed4164bc0df9c6ed89e2f00d74 /dev-ros/self_test/self_test-1.8.9.ebuild
parentdev-ros/diagnostic_updater: Bump to 1.8.9. (diff)
downloadgentoo-6121fc2130eb7280b4171935f1eb0ae2f2046f88.tar.gz
gentoo-6121fc2130eb7280b4171935f1eb0ae2f2046f88.tar.bz2
gentoo-6121fc2130eb7280b4171935f1eb0ae2f2046f88.zip
dev-ros/self_test: Bump to 1.8.9.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/self_test/self_test-1.8.9.ebuild')
-rw-r--r--dev-ros/self_test/self_test-1.8.9.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/self_test/self_test-1.8.9.ebuild b/dev-ros/self_test/self_test-1.8.9.ebuild
new file mode 100644
index 000000000000..031f298dd431
--- /dev/null
+++ b/dev-ros/self_test/self_test-1.8.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Robot self-test node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs
+ dev-ros/diagnostic_updater
+ dev-ros/roscpp
+ dev-ros/rostest
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest )"