summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-12 15:42:31 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-12 15:47:00 +0100
commit2d1bd25e628ca0dc88835be331760f812cbf538b (patch)
treec1dd4bab57a0c5d7d15db0f118e5ae172a90821b /dev-ros/test_rosmaster
parentdev-ros/rosmsg: fix tests (diff)
downloadgentoo-2d1bd25e628ca0dc88835be331760f812cbf538b.tar.gz
gentoo-2d1bd25e628ca0dc88835be331760f812cbf538b.tar.bz2
gentoo-2d1bd25e628ca0dc88835be331760f812cbf538b.zip
dev-ros/test_rosmaster: upstream py3 fixes
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_rosmaster')
-rw-r--r--dev-ros/test_rosmaster/files/py3.patch54
-rw-r--r--dev-ros/test_rosmaster/test_rosmaster-1.14.3-r2.ebuild (renamed from dev-ros/test_rosmaster/test_rosmaster-1.14.3-r1.ebuild)2
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-ros/test_rosmaster/files/py3.patch b/dev-ros/test_rosmaster/files/py3.patch
new file mode 100644
index 000000000000..579d24f9f0b5
--- /dev/null
+++ b/dev-ros/test_rosmaster/files/py3.patch
@@ -0,0 +1,54 @@
+From 8f22c20e418abe4abe23e789eef517a16a50604d Mon Sep 17 00:00:00 2001
+From: Dirk Thomas <dirk-thomas@users.noreply.github.com>
+Date: Tue, 6 Aug 2019 12:50:24 -0700
+Subject: [PATCH] more Python 3 compatibility (#1782)
+
+---
+ test/test_rosmaster/test/nodes/testAllCommonFlows | 2 +-
+ test/test_rosmaster/test/nodes/testMaster | 2 +-
+ test/test_rosmaster/test/nodes/testSlave | 2 +-
+ test/test_rospy/test/unit/test_genmsg_py.py | 8 +++++++-
+ tools/rosgraph/test/test_roslogging.py | 5 ++++-
+ tools/rosgraph/test/test_roslogging_user_logger.py | 5 ++++-
+ tools/roslaunch/src/roslaunch/depends.py | 8 ++++----
+ 7 files changed, 22 insertions(+), 10 deletions(-)
+
+diff --git a/test/test_rosmaster/test/nodes/testAllCommonFlows b/test/test_rosmaster/test/nodes/testAllCommonFlows
+index 4d3e053f8..a22ffb8d8 100755
+--- a/test/test_rosmaster/test/nodes/testAllCommonFlows
++++ b/test/test_rosmaster/test/nodes/testAllCommonFlows
+@@ -12,7 +12,7 @@ import sys, os
+ BOOTSTRAP_VERSION = "0.1"
+
+ # Read in ROS_ROOT
+-if not os.environ.has_key('ROS_ROOT'):
++if 'ROS_ROOT' not in os.environ:
+ print """\nCannot run ROS: ROS_ROOT is not set.\nPlease set the ROS_ROOT environment variable to the
+ location of your ROS install.\n"""
+ sys.exit(-1)
+diff --git a/test/test_rosmaster/test/nodes/testMaster b/test/test_rosmaster/test/nodes/testMaster
+index f3ec36be4..4dca1cb4a 100755
+--- a/test/test_rosmaster/test/nodes/testMaster
++++ b/test/test_rosmaster/test/nodes/testMaster
+@@ -12,7 +12,7 @@ import sys, os
+ BOOTSTRAP_VERSION = "0.1"
+
+ # Read in ROS_ROOT
+-if not os.environ.has_key('ROS_ROOT'):
++if 'ROS_ROOT' not in os.environ:
+ print """\nCannot run ROS: ROS_ROOT is not set.\nPlease set the ROS_ROOT environment variable to the
+ location of your ROS install.\n"""
+ sys.exit(-1)
+diff --git a/test/test_rosmaster/test/nodes/testSlave b/test/test_rosmaster/test/nodes/testSlave
+index cf70af08b..f8ea7cb47 100755
+--- a/test/test_rosmaster/test/nodes/testSlave
++++ b/test/test_rosmaster/test/nodes/testSlave
+@@ -12,7 +12,7 @@ import sys, os
+ BOOTSTRAP_VERSION = "0.1"
+
+ # Read in ROS_ROOT
+-if not os.environ.has_key('ROS_ROOT'):
++if 'ROS_ROOT' not in os.environ:
+ print """\nCannot run ROS: ROS_ROOT is not set.\nPlease set the ROS_ROOT environment variable to the
+ location of your ROS install.\n"""
+ sys.exit(-1)
diff --git a/dev-ros/test_rosmaster/test_rosmaster-1.14.3-r1.ebuild b/dev-ros/test_rosmaster/test_rosmaster-1.14.3-r2.ebuild
index 3d61a62f82a8..d09c050ee2a7 100644
--- a/dev-ros/test_rosmaster/test_rosmaster-1.14.3-r1.ebuild
+++ b/dev-ros/test_rosmaster/test_rosmaster-1.14.3-r2.ebuild
@@ -23,7 +23,7 @@ RDEPEND="dev-ros/rosgraph[${PYTHON_USEDEP}]
DEPEND="${RDEPEND}
test? ( dev-ros/roslib[${PYTHON_USEDEP}] )
"
-PATCHES=( "${FILESDIR}/yaml.patch" "${FILESDIR}/empty.patch" )
+PATCHES=( "${FILESDIR}/yaml.patch" "${FILESDIR}/empty.patch" "${FILESDIR}/py3.patch" )
mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )