summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-24 10:41:30 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-24 10:43:09 +0200
commit897a506674647d46b6fd9564b2c54dfc7da3d4ce (patch)
treed5c2f304393705ece9734440d8e354930bc1b32b /dev-ros/visp_camera_calibration/visp_camera_calibration-9999.ebuild
parentdev-ros/visp_auto_tracker: Initial import. Ebuild by me. (diff)
downloadgentoo-897a506674647d46b6fd9564b2c54dfc7da3d4ce.tar.gz
gentoo-897a506674647d46b6fd9564b2c54dfc7da3d4ce.tar.bz2
gentoo-897a506674647d46b6fd9564b2c54dfc7da3d4ce.zip
dev-ros/visp_camera_calibration: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/visp_camera_calibration/visp_camera_calibration-9999.ebuild')
-rw-r--r--dev-ros/visp_camera_calibration/visp_camera_calibration-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/visp_camera_calibration/visp_camera_calibration-9999.ebuild b/dev-ros/visp_camera_calibration/visp_camera_calibration-9999.ebuild
new file mode 100644
index 000000000000..f18c05f6b65a
--- /dev/null
+++ b/dev-ros/visp_camera_calibration/visp_camera_calibration-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/lagadic/vision_visp"
+KEYWORDS="~amd64 ~arm"
+VER_PREFIX="jade-"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/sensor_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Calibration of cameras using a customizable pattern and ViSP library"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/camera_calibration_parsers
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/visp_bridge
+ sci-libs/ViSP:=
+"
+DEPEND="${RDEPEND}"
+if [ "${PV#9999}" = "${PV}" ] ; then
+ S="${WORKDIR}/vision_visp-jade-${PV}/${ROS_SUBDIR}"
+fi