summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-10-26 09:16:52 +0200
committerHans de Graaff <graaff@gentoo.org>2024-10-26 09:47:52 +0200
commitee6319f12e29bf87e3fd31da27359bed1adf995e (patch)
treeb8efede15118d4a0ff052556467c1d796d206e18 /dev-ruby/activesupport
parentmedia-libs/rubberband: bump to 4.0.0 (diff)
downloadgentoo-ee6319f12e29bf87e3fd31da27359bed1adf995e.tar.gz
gentoo-ee6319f12e29bf87e3fd31da27359bed1adf995e.tar.bz2
gentoo-ee6319f12e29bf87e3fd31da27359bed1adf995e.zip
dev-ruby/activesupport: add 6.1.7.10
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-6.1.7.10.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index 4086f4650837..046023b83751 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -1,3 +1,4 @@
+DIST rails-6.1.7.10.tgz 11034185 BLAKE2B 569fcde5a788151af1eb1bfe7a83048e92bdca36a3e219848567aec47877d17d791ba9f5e4913e077d458e52e7a6b69d448e1763b68e8284b9de4d2a60feaaab SHA512 ae601abca73cb6b962a9863fece1bca2e9ab64ef884054df58ec51cbc8256e9dc26086ade7c0c24c37a2047fd9f21f121ac22b44384bcd877df1d300aa06fe79
DIST rails-6.1.7.8.tgz 11041890 BLAKE2B 285571972ec1d43ae65f3c4f586679e31d0550263c4778925c5828000d6ba971a791ad1071a7ab5edd8d728cd51ee15bb5cee1261b828a4b5926a54f34887d10 SHA512 8c819da0f46820f05d4128444fb3c3908d5e50f97935b173cdd156a986720dda6bcbb62015884d3142ebd5b17621e3f94ca2c80691564914088e884b9aac3573
DIST rails-6.1.7.9.tgz 11034686 BLAKE2B 12edf62a94e0b504f1db721081ce35a6b7e8f67bded2801ce54872f7cef80fb75120f56b356940a44d943cbd05b4d63778726885ac20dd04a2e5510f54ea06ac SHA512 387cbc5424b16ade97091e3cfc3a5bc0cfe277ee75a7f35cdf5d393c692d2ea17f258e38d8b25c8c8a1be4fb64a39d0f675b23942145929bb7be4783cd95d90b
DIST rails-7.0.8.4.tgz 11082427 BLAKE2B 2ca521ad92b7a33fa2160b4cfbc1aac826641d2aac7a8751b6acaed1b7fc42bb860b4ade3f973eb51dc17d20fa4c97b02e8d6b970ae63b042cd58ab2f6cfc797 SHA512 e6628e901fcdcd4b9101cdae0cd556569fc7b577466a15f99d1e221c1c0059287dce87c1362df8b23ded992e96c551b35c0c789e683f080079e678555b7a79e6
diff --git a/dev-ruby/activesupport/activesupport-6.1.7.10.ebuild b/dev-ruby/activesupport/activesupport-6.1.7.10.ebuild
new file mode 100644
index 000000000000..d2408c06c880
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-6.1.7.10.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/concurrent-ruby-1.0.2:1
+ >=dev-ruby/i18n-1.6:1
+ >=dev-ruby/minitest-5.1
+ dev-ruby/tzinfo:2
+ >=dev-ruby/zeitwerk-2.3:2
+"
+
+# memcache-client, nokogiri, builder, and redis are not strictly needed,
+# but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-3.0.1
+ dev-ruby/connection_pool
+ >=dev-ruby/nokogiri-1.8.1
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/listen-3.3:3
+ dev-ruby/rack
+ dev-ruby/rexml
+ dev-ruby/mocha
+ <dev-ruby/minitest-5.16:*
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.1.7.3-ruby-thread-noise.patch
+ "${FILESDIR}"/${PN}-6.1.7.4-bytesplice.patch
+ "${FILESDIR}"/${PN}-6.1.7.4-class_serial.patch
+)
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|sqlite\|websocket-client-simple\|\libxml-ruby\|bootsnap\|aws-sdk\|webmock\|capybara\|sass-rails\|selenium-webdriver\|webpacker\|webrick\|rack-test\|net-smtp\|net-imap\|net-pop\|digest\|matrix\)/ s:^:#:" \
+ -e '/group :\(doc\|rubocop\|job\|cable\|storage\|ujs\|test\) do/,/^end/ s:^:#:' \
+ -e 's/gemspec/gemspec path: "activesupport"/' \
+ -e '5igem "builder"; gem "rack"' ../Gemfile || die
+ rm ../Gemfile.lock || die
+# sed -i -e '1igem "tzinfo", "~> 1.1"' test/abstract_unit.rb || die
+
+ # Avoid test that depends on timezone and test that fails on 32-bit arches
+ sed -e '/test_implicit_coercion/,/^ end/ s:^:#:' \
+ -e '/test_iso8601_output_and_reparsing/askip "Broken on 32-bit arches"' \
+ -i test/core_ext/duration_test.rb || die
+
+ # Avoid tests that seem to trigger race conditions.
+ rm -f test/evented_file_update_checker_test.rb || die
+
+ # Avoid test that generates filename that is too long
+ sed -i -e '/test_filename_max_size/askip "gentoo"' test/cache/stores/file_store_test.rb || die
+
+ # Avoid tests requiring a live redis running
+ rm -f test/cache/stores/redis_cache_store_test.rb || die
+ sed -i -e '/cache_stores:redis/ s:^:#:' Rakefile || die
+ sed -i -e '/test_redis_cache_store/askip "lacking keywords"' test/cache/cache_store_setting_test.rb || die
+}