summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-03-04 09:16:47 +0100
committerHans de Graaff <graaff@gentoo.org>2023-03-04 09:28:19 +0100
commitf2efe089367872258ac339bb743b16b1c9a5a31a (patch)
treee1086d1a1dff3677020492dbd2f9f54a446c96d4 /dev-ruby/autoprefixer-rails
parentapp-emulation/qemu-guest-agent: Stabilize 7.1.0 amd64, #899240 (diff)
downloadgentoo-f2efe089367872258ac339bb743b16b1c9a5a31a.tar.gz
gentoo-f2efe089367872258ac339bb743b16b1c9a5a31a.tar.bz2
gentoo-f2efe089367872258ac339bb743b16b1c9a5a31a.zip
dev-ruby/autoprefixer-rails: add 10.4.13.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/autoprefixer-rails')
-rw-r--r--dev-ruby/autoprefixer-rails/Manifest1
-rw-r--r--dev-ruby/autoprefixer-rails/autoprefixer-rails-10.4.13.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/autoprefixer-rails/Manifest b/dev-ruby/autoprefixer-rails/Manifest
index 07dee81782bb..7cb5e1c13876 100644
--- a/dev-ruby/autoprefixer-rails/Manifest
+++ b/dev-ruby/autoprefixer-rails/Manifest
@@ -1 +1,2 @@
+DIST autoprefixer-rails-10.4.13.0.tar.gz 1386370 BLAKE2B a96eb20ebb940a63abf22819e7b2c1727816e4e70cffff5fce3f84c09b783c7f6aac3d6af2483670bbacf4e8032e71f8b144bdc41846464935dbf57fa23d98f5 SHA512 698e8f91875d7fe73d4843cd4dda65b695e3654b9bbf02070a0fd4d61ebf9fb00aaffa8ce63b738dc5d345c5536c79fa985adfa779f47d57412c791e3388cc97
DIST autoprefixer-rails-10.4.7.0.tar.gz 1372138 BLAKE2B 5d4ad1cb82fc0e82557232fc1a050f87fc2758967c21e2e566049686efec41b599e3cf7e2b432d164c6a29c2463ab3c695703878c23188ee97a46e5aff6a26a2 SHA512 c1d3a1200c05a3b1219716058eb28babef4bc26eaca1ebdc09a901709435f25f097d3c39398a07283a75ed37b30a45398fbe31095e649f6d94fdc6de2346aad6
diff --git a/dev-ruby/autoprefixer-rails/autoprefixer-rails-10.4.13.0.ebuild b/dev-ruby/autoprefixer-rails/autoprefixer-rails-10.4.13.0.ebuild
new file mode 100644
index 000000000000..a5f07fb4f9a8
--- /dev/null
+++ b/dev-ruby/autoprefixer-rails/autoprefixer-rails-10.4.13.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="vendor"
+
+RUBY_FAKEGEM_GEMSPEC="autoprefixer-rails.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Add vendor prefixes to CSS rules using values from the Can I Use website"
+HOMEPAGE="https://github.com/ai/autoprefixer-rails"
+SRC_URI="https://github.com/ai/autoprefixer-rails/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+DEPEND+="test? ( net-libs/nodejs )"
+
+ruby_add_rdepend "dev-ruby/execjs"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rails-5.0.0
+ dev-ruby/rake
+ dev-ruby/rspec-rails
+ dev-ruby/sprockets-rails
+)"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" -e "/BUNDLE/d" spec/app/config/boot.rb || die
+ sed -i -e "/Bundler/ s:^:#:" \
+ -e '/config.sass/ s:^:#:' spec/app/config/application.rb || die
+ rm -f spec/rails_spec.rb || die
+}