summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-08-03 06:40:30 +0200
committerHans de Graaff <graaff@gentoo.org>2021-08-03 06:54:08 +0200
commit4417a4f071715b29e95928382614942af68bedb8 (patch)
treeb20140ec115437234be552e14ae8467e810c1bdc /dev-ruby/globalid/globalid-0.5.2.ebuild
parentapp-emacs/magit: add 3.2.0 (diff)
downloadgentoo-4417a4f071715b29e95928382614942af68bedb8.tar.gz
gentoo-4417a4f071715b29e95928382614942af68bedb8.tar.bz2
gentoo-4417a4f071715b29e95928382614942af68bedb8.zip
dev-ruby/globalid: add 0.5.2
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/globalid/globalid-0.5.2.ebuild')
-rw-r--r--dev-ruby/globalid/globalid-0.5.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/globalid/globalid-0.5.2.ebuild b/dev-ruby/globalid/globalid-0.5.2.ebuild
new file mode 100644
index 000000000000..8795d175a2a6
--- /dev/null
+++ b/dev-ruby/globalid/globalid-0.5.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="globalid.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Reference models by URI"
+HOMEPAGE="https://github.com/rails/globalid"
+SRC_URI="https://github.com/rails/globalid/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bundler >=dev-ruby/activemodel-5.0 >=dev-ruby/railties-5.0 )"
+ruby_add_rdepend ">=dev-ruby/activesupport-5.0:*"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+
+ sed -i -e '2irequire "forwardable"' test/helper.rb || die
+}