summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-08-21 10:52:10 +0200
committerHans de Graaff <graaff@gentoo.org>2021-08-23 19:38:11 +0200
commitb89b42d256b67e83a35f73888b7de0ef6bba6299 (patch)
tree550d0fe24f71b972e601de561a3931abcce170df /dev-ruby/jwt/jwt-2.2.3.ebuild
parentdev-ruby/haml: add 5.2.2 (diff)
downloadgentoo-b89b42d256b67e83a35f73888b7de0ef6bba6299.tar.gz
gentoo-b89b42d256b67e83a35f73888b7de0ef6bba6299.tar.bz2
gentoo-b89b42d256b67e83a35f73888b7de0ef6bba6299.zip
dev-ruby/jwt: add 2.2.3
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/jwt/jwt-2.2.3.ebuild')
-rw-r--r--dev-ruby/jwt/jwt-2.2.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/jwt/jwt-2.2.3.ebuild b/dev-ruby/jwt/jwt-2.2.3.ebuild
new file mode 100644
index 000000000000..bed4ee7f5a63
--- /dev/null
+++ b/dev-ruby/jwt/jwt-2.2.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="ruby-jwt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby implementation of JSON Web Token draft 06"
+HOMEPAGE="https://github.com/jwt/ruby-jwt"
+SRC_URI="https://github.com/jwt/ruby-jwt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="ruby-jwt-${PV}"
+
+PATCHES=( "${FILESDIR}/${P}-ec-test.patch" )
+
+ruby_add_bdepend "test? ( dev-ruby/rbnacl )"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/ s:^:#:" \
+ -e '/^SimpleCov.start/,/^end/ s:^:#:' \
+ spec/spec_helper.rb || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}