summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-10-26 07:49:10 +0200
committerHans de Graaff <graaff@gentoo.org>2019-10-26 07:49:10 +0200
commit2012f15fdbec697478a758ae94ca268f013325af (patch)
tree480a6ff245715fbd0827bd8de15e21b47c1375f2 /dev-ruby/neovim-ruby-client/neovim-ruby-client-0.8.1-r1.ebuild
parentdev-ruby/hocon: add 1.2.6 (diff)
downloadgentoo-2012f15fdbec697478a758ae94ca268f013325af.tar.gz
gentoo-2012f15fdbec697478a758ae94ca268f013325af.tar.bz2
gentoo-2012f15fdbec697478a758ae94ca268f013325af.zip
dev-ruby/neovim-ruby-client: specify "exe" bindir
Fixes: https://bugs.gentoo.org/698472 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/neovim-ruby-client/neovim-ruby-client-0.8.1-r1.ebuild')
-rw-r--r--dev-ruby/neovim-ruby-client/neovim-ruby-client-0.8.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/neovim-ruby-client/neovim-ruby-client-0.8.1-r1.ebuild b/dev-ruby/neovim-ruby-client/neovim-ruby-client-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..640c16bb6dd2
--- /dev/null
+++ b/dev-ruby/neovim-ruby-client/neovim-ruby-client-0.8.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_NAME="neovim"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINDIR="exe"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby bindings for Neovim"
+HOMEPAGE="https://github.com/alexgenco/neovim-ruby"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+ruby_add_rdepend "
+ >=dev-ruby/msgpack-1.1:0
+ =dev-ruby/multi_json-1*
+"
+
+all_ruby_prepare() {
+ sed -i -e '/\(bundler\|pry\)/ s:^:#:' spec/helper.rb || die
+
+ # Avoid tests that result in a unix socket path that is too long
+ sed -i -e '/\(establishes an RPC connection\|sets appropriate client info\)/askip "socket path length"' spec/neovim_spec.rb || die
+}