summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-07-25 07:46:17 +0200
committerHans de Graaff <graaff@gentoo.org>2019-07-25 07:55:15 +0200
commitecdbfb0bd91561ee5cc973f2629d09070491b443 (patch)
tree432d627029f9c9652d4f755e15a448e720242dbd /dev-ruby/net-http-persistent
parentdev-python/cmd2: Bump to 0.9.15 (diff)
downloadgentoo-ecdbfb0bd91561ee5cc973f2629d09070491b443.tar.gz
gentoo-ecdbfb0bd91561ee5cc973f2629d09070491b443.tar.bz2
gentoo-ecdbfb0bd91561ee5cc973f2629d09070491b443.zip
dev-ruby/net-http-persistent: add 3.1.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/net-http-persistent')
-rw-r--r--dev-ruby/net-http-persistent/Manifest1
-rw-r--r--dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/net-http-persistent/Manifest b/dev-ruby/net-http-persistent/Manifest
index a08beffa0bd4..54d1eedba3f1 100644
--- a/dev-ruby/net-http-persistent/Manifest
+++ b/dev-ruby/net-http-persistent/Manifest
@@ -1,3 +1,4 @@
DIST net-http-persistent-2.9.4.gem 31232 BLAKE2B 54388d26971c3ea3353e0c39acd00fe77befd66e408c54be13f7ecea194517a2e71b8d9bebb1238f4d36d7be96584c0be9e6a7bbc44f81f88004dd118fa56311 SHA512 9251e8422c2f43e7ecd8bc287fa9fff682fac84ed95d143425b0e7e7678a06c9be01db56e6a956588d6c33ddccbd1eff45a6f399f43d452de8e3134e6c50b74e
DIST net-http-persistent-3.0.0.gem 30208 BLAKE2B 2bbd87d66e65081c76bc9cddaeb38f3ffd8a92b5b64f7717f77c7a927e2032fa732c2e82e220a75a63ddc10dfaa6a0f24e4fa7e0964e2ebd3d0729127f1fb452 SHA512 a601d3abde43b196406e3cdd6b704796ed70db67dfb67c9b510e0164ce7355cc925cac37fbf4c5889f41b069890ba2e2c15440fb40294ed21891fd08d9f87894
DIST net-http-persistent-3.0.1.gem 26112 BLAKE2B 987e7c690d1e08e6be490aaecbd42ec8dc95fe5d2dc3609313b5be301453e4a30a66486334419e2ce9af9bd08158c3b78600cd8364fc6f489529ca1657436ee3 SHA512 33f23c6d23a8d2e44c0268e720200e4e19ba50bbfb9268a3c7af653fbfff62e606f1d10b2ff35ea345f4f7c0456892a901753257da87e9a2bb329edd36030761
+DIST net-http-persistent-3.1.0.gem 31744 BLAKE2B fdd9c36ab5216c1cd1fe358207a689276e109845ac374ea16011469b6cb2b165115e78e701cce98c280e7f878c23d8016e75cac4508c7e579209012671b64101 SHA512 65b5afc4ad0729ec14b642e0e36363cecfff3dc25b26308d632866e93fed3eccfb83ce85da78f631553c6a1fe3ee834fcbc9d3681c85db6387463abbc30e60fa
diff --git a/dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild b/dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild
new file mode 100644
index 000000000000..b1b172d1e070
--- /dev/null
+++ b/dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Manages persistent connections using Net::HTTP plus a speed fix for Ruby 1.8"
+HOMEPAGE="https://github.com/drbrain/net-http-persistent"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend ">=dev-ruby/connection_pool-2.2:0"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/hoe dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # avoid test with implicit dependency on net-http-pipeline which
+ # fails and is not tested upstream
+ sed -i -e '/net-http-pipeline not installed/ s/unless.*$//' test/test_net_http_persistent.rb || die
+}