summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-03-31 10:43:09 +0200
committerHans de Graaff <graaff@gentoo.org>2023-04-01 08:25:35 +0200
commit62583ea25873e907e527964887b539a4bdae8177 (patch)
tree37dd26b4862bbc271421f8b3bcec7bf13af142ba /dev-ruby/pathutil
parentdev-ruby/safe_yaml: update EAPI 7 -> 8, add ruby30 (diff)
downloadgentoo-62583ea25873e907e527964887b539a4bdae8177.tar.gz
gentoo-62583ea25873e907e527964887b539a4bdae8177.tar.bz2
gentoo-62583ea25873e907e527964887b539a4bdae8177.zip
dev-ruby/pathutil: update EAPI 6 -> 8, add ruby30
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/pathutil')
-rw-r--r--dev-ruby/pathutil/pathutil-0.16.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/pathutil/pathutil-0.16.2-r1.ebuild b/dev-ruby/pathutil/pathutil-0.16.2-r1.ebuild
new file mode 100644
index 000000000000..a2d80d2c8ccf
--- /dev/null
+++ b/dev-ruby/pathutil/pathutil-0.16.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="Gem.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Like Pathname but a little less insane"
+HOMEPAGE="https://rubygems.org/gems/pathutil https://github.com/envygeeks/pathutil"
+SRC_URI="https://github.com/envygeeks/pathutil/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${P}-ruby30.patch" )
+
+ruby_add_rdepend ">=dev-ruby/forwardable-extended-2.6
+ <dev-ruby/forwardable-extended-3"
+
+ruby_add_bdepend "test? ( dev-ruby/safe_yaml )"
+
+all_ruby_prepare() {
+ sed -i -e '/\(coverage\|luna\|rspec\/helpers\)/ s:^:#:' \
+ -e '1irequire "pathname"; require "tempfile"; require "tmpdir"; require "json" ; gem "psych", "~> 3.0"' \
+ spec/rspec/helper.rb || die
+ rm -f spec/support/coverage.rb || die
+}