summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2015-09-04 17:02:30 -0400
committerZero_Chaos <zerochaos@gentoo.org>2015-09-04 17:02:50 -0400
commit02bd428e62ca2cba9e41b923386b564283caa763 (patch)
tree32b4db545f0dc73d144a950f2a1383ec01375faf /dev-ruby/postgres_ext
parentnet-misc/dhcpcd: version bump (diff)
downloadgentoo-02bd428e62ca2cba9e41b923386b564283caa763.tar.gz
gentoo-02bd428e62ca2cba9e41b923386b564283caa763.tar.bz2
gentoo-02bd428e62ca2cba9e41b923386b564283caa763.zip
net-analyzer/metasploit: add a modern version of metasploit (and a ton of deps for it)
Diffstat (limited to 'dev-ruby/postgres_ext')
-rw-r--r--dev-ruby/postgres_ext/Manifest1
-rw-r--r--dev-ruby/postgres_ext/metadata.xml13
-rw-r--r--dev-ruby/postgres_ext/postgres_ext-2.4.1.ebuild50
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-ruby/postgres_ext/Manifest b/dev-ruby/postgres_ext/Manifest
new file mode 100644
index 000000000000..a0525a902f8e
--- /dev/null
+++ b/dev-ruby/postgres_ext/Manifest
@@ -0,0 +1 @@
+DIST postgres_ext-2.4.1.gem 20992 SHA256 41d5bd383537e90833005f87fe502843ee7097c5a981e81f7ed8464635d89df3 SHA512 e8a0b2990e2939f600c92bfae70ebfb142875ca3b86d6d6ad95bc8bbaf350df8c2fde5173f51ff71616e5b68d7d852d1f4b201573c05afa39aa4134c9cb4ef75 WHIRLPOOL 8d2126b0717c7f4311bd171542dd76db8d56c6b07cdd05400af7130a9e8f06df324faf4ca5aacbddfb31fdfeedf2e40bb9f960f1cbd515f3687dbe5a31c1a622
diff --git a/dev-ruby/postgres_ext/metadata.xml b/dev-ruby/postgres_ext/metadata.xml
new file mode 100644
index 000000000000..5ff2ea70d7e1
--- /dev/null
+++ b/dev-ruby/postgres_ext/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+<longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">dockyard/postgres_ext</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/postgres_ext/postgres_ext-2.4.1.ebuild b/dev-ruby/postgres_ext/postgres_ext-2.4.1.ebuild
new file mode 100644
index 000000000000..a009b828757a
--- /dev/null
+++ b/dev-ruby/postgres_ext/postgres_ext-2.4.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Adds native PostgreSQL data types to ActiveRecord and querying extensions for ActiveRecord and Arel"
+HOMEPAGE="https://github.com/dockyard/postgres_ext"
+SRC_URI="mirror://rubygems/${P}.gem"
+
+LICENSE="BSD"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT=test
+
+ruby_add_rdepend "|| ( dev-ruby/activerecord:4.1 dev-ruby/activerecord:4.2 )
+ >=dev-ruby/arel-4.0.1:*
+ dev-ruby/pg_array_parser:0.0.9"
+
+ruby_add_bdepend "dev-ruby/bundler"
+
+all_ruby_prepare() {
+ [ -f Gemfile.lock ] && rm Gemfile.lock
+ #if ! use development; then
+ sed -i -e "/^group :development do/,/^end$/d" Gemfile || die
+ sed -i -e "/s.add_development_dependency/d" "${PN}".gemspec || die
+ sed -i -e "/gem.add_development_dependency/d" "${PN}".gemspec || die
+ #fi
+ #if ! use test; then
+ sed -i -e "/^group :test do/,/^end$/d" Gemfile || die
+ #fi
+ #if ! use test && ! use development; then
+ sed -i -e "/^group :development, :test do/,/^end$/d" Gemfile || die
+ #fi
+ #https://github.com/dockyard/postgres_ext/issues/166
+ #ugh, thanks
+ sed -i -e "/byebug/d" Gemfile || die
+ sed -i -e "/fivemat/d" Gemfile || die
+}
+
+each_ruby_prepare() {
+ if [ -f Gemfile ]; then
+ BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle install --local || die
+ BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle check || die
+ fi
+}