summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/samuel/samuel-0.3.3-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/samuel/samuel-0.3.3-r2.ebuild')
-rw-r--r--dev-ruby/samuel/samuel-0.3.3-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/samuel/samuel-0.3.3-r2.ebuild b/dev-ruby/samuel/samuel-0.3.3-r2.ebuild
new file mode 100644
index 000000000000..21d21147509f
--- /dev/null
+++ b/dev-ruby/samuel/samuel-0.3.3-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="An automatic logger for HTTP requests in Ruby"
+HOMEPAGE="https://github.com/chrisk/samuel"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/shoulda-2.11.3
+ >=dev-ruby/fakeweb-1.3
+ >=dev-ruby/httpclient-2.2.3
+ dev-ruby/mocha:0.14
+ dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ # Remove references to bundler
+ sed -i -e '/[Bb]undler/d' test/test_helper.rb || die
+ rm Gemfile*
+
+ # Change the default port from 8000 to 64888 to sidestep Issue #10.
+ # https://github.com/chrisk/samuel/issues/10
+ sed -i -e 's:8000:64888:g' test/*.rb || die
+
+ # Require an old enough version of mocha.
+ sed -i -e '1igem "mocha", "~> 0.14.0"' test/test_helper.rb || die
+
+ # Use the test-unit gem to make jruby compatible with newer mocha.
+ sed -i -e '1igem "test-unit"' test/test_helper.rb || die
+}