summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-10-04 07:36:51 +0200
committerHans de Graaff <graaff@gentoo.org>2019-10-04 08:02:06 +0200
commit6302b9721b7ccbb2e588cae1947138a062fbffb5 (patch)
tree11c2ab983a2c069913acb2024b1651d1b5f6c3ed /dev-ruby/selenium-webdriver/selenium-webdriver-3.142.6.ebuild
parentmedia-gfx/qimgv: remove old 0.8.2 (diff)
downloadgentoo-6302b9721b7ccbb2e588cae1947138a062fbffb5.tar.gz
gentoo-6302b9721b7ccbb2e588cae1947138a062fbffb5.tar.bz2
gentoo-6302b9721b7ccbb2e588cae1947138a062fbffb5.zip
dev-ruby/selenium-webdriver: add 3.142.6
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/selenium-webdriver/selenium-webdriver-3.142.6.ebuild')
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-3.142.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-3.142.6.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-3.142.6.ebuild
new file mode 100644
index 000000000000..da443bc4017a
--- /dev/null
+++ b/dev-ruby/selenium-webdriver/selenium-webdriver-3.142.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+# NOTE: this package contains precompiled code. It appears that all
+# source code can be found at https://code.google.com/p/selenium/ but the
+# repository is not organized in a way so that we can easily rebuild the
+# suited shared object. We'll just try our luck with the precompiled
+# objects for now.
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
+QA_PREBUILT="*/x_ignore_nofocus.so"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem provides Ruby bindings for WebDriver"
+HOMEPAGE="https://github.com/seleniumhq/selenium"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/childprocess-0.5:2
+ >=dev-ruby/rubyzip-1.2.2:*"