summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-10-15 08:11:49 +0200
committerHans de Graaff <graaff@gentoo.org>2022-10-15 08:11:59 +0200
commitcbfdd88a0df29749122fbb448d36f63d9235d73c (patch)
treedb3895c8480ba7c518e997341d8f39faf571f99a /dev-ruby/sprockets-rails
parentdev-ruby/sassc-rails: drop 2.1.2-r1 (diff)
downloadgentoo-cbfdd88a0df29749122fbb448d36f63d9235d73c.tar.gz
gentoo-cbfdd88a0df29749122fbb448d36f63d9235d73c.tar.bz2
gentoo-cbfdd88a0df29749122fbb448d36f63d9235d73c.zip
dev-ruby/sprockets-rails: enable ruby31 and disable ruby26
Correct the fix for running the tests in a predictable order. Closes: https://bugs.gentoo.org/872467 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/sprockets-rails')
-rw-r--r--dev-ruby/sprockets-rails/sprockets-rails-3.4.2-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-ruby/sprockets-rails/sprockets-rails-3.4.2-r1.ebuild b/dev-ruby/sprockets-rails/sprockets-rails-3.4.2-r1.ebuild
index a3e90d048c61..6a4a0eb4d179 100644
--- a/dev-ruby/sprockets-rails/sprockets-rails-3.4.2-r1.ebuild
+++ b/dev-ruby/sprockets-rails/sprockets-rails-3.4.2-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30"
+USE_RUBY="ruby27 ruby30 ruby31"
RUBY_FAKEGEM_TASK_DOC=""
@@ -35,5 +35,5 @@ all_ruby_prepare() {
sed -i -e '/bundler/ s:^:#:' Rakefile || die
# It looks like tests are order dependent
- sed -i -e '/test_order/ s/:alpha/:random/' test/test_helper.rb || die
+ sed -i -e '/test_order/ s/:random/:alpha/' test/test_helper.rb || die
}