summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-11-02 06:38:56 +0100
committerHans de Graaff <graaff@gentoo.org>2019-11-02 06:38:56 +0100
commit91f816c722c78fcb38a341ed09d94e77f291dad8 (patch)
tree0eb73ea6e4518db43d8fe129d903f545e260027e /dev-ruby/tins/tins-1.22.0.ebuild
parentdev-ruby/roadie: add 4.0.0 (diff)
downloadgentoo-91f816c722c78fcb38a341ed09d94e77f291dad8.tar.gz
gentoo-91f816c722c78fcb38a341ed09d94e77f291dad8.tar.bz2
gentoo-91f816c722c78fcb38a341ed09d94e77f291dad8.zip
dev-ruby/tins: add 1.22.0
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/tins/tins-1.22.0.ebuild')
-rw-r--r--dev-ruby/tins/tins-1.22.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/tins/tins-1.22.0.ebuild b/dev-ruby/tins/tins-1.22.0.ebuild
new file mode 100644
index 000000000000..074a4469878f
--- /dev/null
+++ b/dev-ruby/tins/tins-1.22.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="All the stuff that isn't good enough for a real library"
+HOMEPAGE="https://github.com/flori/tins"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib tests/*_test.rb
+}