summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2025-01-18 09:07:04 +0100
committerHans de Graaff <graaff@gentoo.org>2025-01-18 09:45:19 +0100
commit82cb0109fc156567973fca5149f908805d882241 (patch)
tree40344d4e88d184c0cc798a30a94c9aab2a033315 /dev-ruby/tokyocabinet
parentwww-apps/jekyll: drop 4.3.3 (diff)
downloadgentoo-82cb0109fc156567973fca5149f908805d882241.tar.gz
gentoo-82cb0109fc156567973fca5149f908805d882241.tar.bz2
gentoo-82cb0109fc156567973fca5149f908805d882241.zip
dev-ruby/tokyocabinet: fix arity of tbdqry_proc method
Closes: https://bugs.gentoo.org/883747 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/tokyocabinet')
-rw-r--r--dev-ruby/tokyocabinet/files/tokyocabinet-1.32.0-arity.patch11
-rw-r--r--dev-ruby/tokyocabinet/tokyocabinet-1.32.0-r2.ebuild25
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/tokyocabinet/files/tokyocabinet-1.32.0-arity.patch b/dev-ruby/tokyocabinet/files/tokyocabinet-1.32.0-arity.patch
new file mode 100644
index 000000000000..f11a6c2cc1c8
--- /dev/null
+++ b/dev-ruby/tokyocabinet/files/tokyocabinet-1.32.0-arity.patch
@@ -0,0 +1,11 @@
+--- a/tokyocabinet.c 2025-01-18 08:58:51.200947224 +0100
++++ b/tokyocabinet.c 2025-01-18 09:03:40.936107401 +0100
+@@ -3164,7 +3164,7 @@
+ rb_define_method(cls_tdbqry, "setmax", tdbqry_setlimit, -1);
+ rb_define_method(cls_tdbqry, "search", tdbqry_search, 0);
+ rb_define_method(cls_tdbqry, "searchout", tdbqry_searchout, 0);
+- rb_define_method(cls_tdbqry, "proc", tdbqry_proc, 0);
++ rb_define_method(cls_tdbqry, "proc", tdbqry_proc, 1);
+ rb_define_method(cls_tdbqry, "hint", tdbqry_hint, 0);
+ rb_define_method(cls_tdbqry, "metasearch", tdbqry_metasearch, -1);
+ rb_define_method(cls_tdbqry, "kwic", tdbqry_kwic, -1);
diff --git a/dev-ruby/tokyocabinet/tokyocabinet-1.32.0-r2.ebuild b/dev-ruby/tokyocabinet/tokyocabinet-1.32.0-r2.ebuild
new file mode 100644
index 000000000000..ac227ed2b1be
--- /dev/null
+++ b/dev-ruby/tokyocabinet/tokyocabinet-1.32.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTENSIONS=(./extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby bindings for Tokyo Cabinet"
+HOMEPAGE="https://fallabs.com/tokyocabinet/"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-db/tokyocabinet"
+
+PATCHES=( "${FILESDIR}/${P}-arity.patch" )