summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-10-18 08:36:40 +0200
committerHans de Graaff <graaff@gentoo.org>2019-10-18 08:37:09 +0200
commit4ba24b32b18acd02f9fba532f4a1be98b2ca9d0a (patch)
tree1bf66a8bee8585132e29d94f79d38d8b364bceff /dev-ruby/wisper/wisper-2.0.1.ebuild
parentdev-ruby/diva: add 1.0.1 (diff)
downloadgentoo-4ba24b32b18acd02f9fba532f4a1be98b2ca9d0a.tar.gz
gentoo-4ba24b32b18acd02f9fba532f4a1be98b2ca9d0a.tar.bz2
gentoo-4ba24b32b18acd02f9fba532f4a1be98b2ca9d0a.zip
dev-ruby/wisper: add 2.0.1
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/wisper/wisper-2.0.1.ebuild')
-rw-r--r--dev-ruby/wisper/wisper-2.0.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/wisper/wisper-2.0.1.ebuild b/dev-ruby/wisper/wisper-2.0.1.ebuild
new file mode 100644
index 000000000000..5231ea77d3e4
--- /dev/null
+++ b/dev-ruby/wisper/wisper-2.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A micro library providing objects with Publish-Subscribe capabilities"
+HOMEPAGE="https://github.com/krisleech/wisper"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/coverall/I s:^:#:' spec/spec_helper.rb || die
+}