summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-21 09:31:12 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-21 09:31:18 +0100
commit6b8e10390993b27a2d5896d52db088054ed367aa (patch)
treea298fb02f6ed196c2a3a703bd697dc3e290edbf3 /dev-ruby/x25519
parentsys-boot/raspberrypi-firmware: add 1.20211029 (diff)
downloadgentoo-6b8e10390993b27a2d5896d52db088054ed367aa.tar.gz
gentoo-6b8e10390993b27a2d5896d52db088054ed367aa.tar.bz2
gentoo-6b8e10390993b27a2d5896d52db088054ed367aa.zip
dev-ruby/x25519: add 1.0.9; fix extension install
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/x25519')
-rw-r--r--dev-ruby/x25519/Manifest1
-rw-r--r--dev-ruby/x25519/x25519-1.0.9.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/x25519/Manifest b/dev-ruby/x25519/Manifest
index 4e3929e2a389..165f3831ce7a 100644
--- a/dev-ruby/x25519/Manifest
+++ b/dev-ruby/x25519/Manifest
@@ -1 +1,2 @@
DIST x25519-1.0.8.tar.gz 44313 BLAKE2B 844408f6bb77b55a2ca0222c46d4d09688838d7fc86517636a465da7fb225d9de2f14fda3d38d593f0feddb5e4aeab28ec900766a190759139bf05f6e0e6bd56 SHA512 42a9a2f1c470ea82c070435e4d85317c69fbd6e994f765c46b3aa4b544a5557559ff36194e37100bd8f581711156d185117535aeb3da9f5b6b5523e5a4b347b6
+DIST x25519-1.0.9.tar.gz 44042 BLAKE2B 65129fdfc0c40099487da3eacbd91436b625fd1224d58139a09d2ec571cb063f69767d468c89af512b0bef81912786b44b6923afaeb4a14f97a47034b702d848 SHA512 48349960b69f88177b772f431a1751ad190a9d71ebb01e0aced7dcc278a18c2e7cb1dbb621524950685b974f2f63d23039973accf067720ce1b74c5bb1eb4f77
diff --git a/dev-ruby/x25519/x25519-1.0.9.ebuild b/dev-ruby/x25519/x25519-1.0.9.ebuild
new file mode 100644
index 000000000000..f00eb3f62157
--- /dev/null
+++ b/dev-ruby/x25519/x25519-1.0.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="x25519.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/x25519_ref10/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Key exchange via the X25519 (Curve25519) Elliptic Curve Diffie-Hellman function"
+HOMEPAGE="https://github.com/crypto-rb/x25519"
+SRC_URI="https://github.com/crypto-rb/x25519/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#: ; /coverall/I s:^:#:' spec/spec_helper.rb || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # The precomputed implementation only works on amd64
+ if use amd64 ; then
+ RUBY_FAKEGEM_EXTENSIONS+=(ext/x25519_precomputed/extconf.rb)
+ else
+ sed -i -e '/\(x25519_precomputed\|X25519::Provider::Precomputed\)/ s:^:#:' lib/x25519.rb || die
+ rm -f spec/x25519/provider/precomputed_spec.rb || die
+ fi
+}