summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-07-22 07:59:11 +0200
committerHans de Graaff <graaff@gentoo.org>2016-07-22 08:00:46 +0200
commit5cf8e105b112f19e66477b719e88f71696afe9b2 (patch)
tree3a4a29eff9326daba93ef08d107b68ac35da35e8 /dev-ruby/yard/yard-0.9.4.ebuild
parentdev-ruby/treetop: add 1.6.8 (diff)
downloadgentoo-5cf8e105b112f19e66477b719e88f71696afe9b2.tar.gz
gentoo-5cf8e105b112f19e66477b719e88f71696afe9b2.tar.bz2
gentoo-5cf8e105b112f19e66477b719e88f71696afe9b2.zip
dev-ruby/yard: add 0.9.4
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/yard/yard-0.9.4.ebuild')
-rw-r--r--dev-ruby/yard/yard-0.9.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/yard/yard-0.9.4.ebuild b/dev-ruby/yard/yard-0.9.4.ebuild
new file mode 100644
index 000000000000..092dda383d57
--- /dev/null
+++ b/dev-ruby/yard/yard-0.9.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_DOCDIR="doc docs"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Documentation generation tool for the Ruby programming language"
+HOMEPAGE="http://yardoc.org/"
+
+# The gem lakes the gemspec file needed to pass tests.
+SRC_URI="https://github.com/lsegal/yard/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( || ( dev-ruby/maruku dev-ruby/rdiscount dev-ruby/bluecloth dev-ruby/kramdown ) )"
+
+USE_RUBY="ruby20 ruby21 ruby22" ruby_add_bdepend "test? ( >=dev-ruby/ruby-gettext-2.3.8 )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid specs that make assumptions on load ordering that are not
+ # true for us. This may be related to how we install in Gentoo. This
+ # also drops a test requirement on dev-ruby/rack.
+ rm -f spec/cli/server_spec.rb || die
+}