summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-10-20 07:19:07 +0200
committerHans de Graaff <graaff@gentoo.org>2023-10-20 07:19:07 +0200
commit093d6b6a5d24a8478d937af81550fcb5169b4a68 (patch)
tree8a1ab8a61f5ef54969f13fcb0cad7237fdaa82ef /dev-ruby
parentdev-python/openstacksdk: Bump to 2.0.0 (diff)
downloadgentoo-093d6b6a5d24a8478d937af81550fcb5169b4a68.tar.gz
gentoo-093d6b6a5d24a8478d937af81550fcb5169b4a68.tar.bz2
gentoo-093d6b6a5d24a8478d937af81550fcb5169b4a68.zip
dev-ruby/thor: add 1.3.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/thor/Manifest1
-rw-r--r--dev-ruby/thor/thor-1.3.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-ruby/thor/Manifest b/dev-ruby/thor/Manifest
index 47249bf44125..c22fc58f6f8b 100644
--- a/dev-ruby/thor/Manifest
+++ b/dev-ruby/thor/Manifest
@@ -1 +1,2 @@
DIST thor-git-1.2.2.tgz 98213 BLAKE2B e71ee51eb5c982c585cf9bd9dffda8933975c9d0df8096015d125eefd0597a653887db1acfc132ce1f5a2e8ce4ab71c790a6c0bf39edd7c5e4c85a75de963944 SHA512 2c8af5d59f33691af63e813ba8dfe3392c279593f3e3ccf0ab2d6eb2ccce4220d93b7cb3413ad853e4bba14f4e2182c54caaf4944627cbcbefa31cdc0fabefc7
+DIST thor-git-1.3.0.tgz 102884 BLAKE2B f3f5a27ccfdbe7de6bbec71e1ae36e522d49ceec223e1d86a028898403e4e56722703dc847b4a850c46301fdeea429e70e73b7888089c35138d455c094678c02 SHA512 f561f9d05264cf0d2cd836dfb689539b645fa02a39ea8d10923001bb3d510ad6b4bcbb6551739d453e7d9ac05562bc0f454b581926becbc784c0604c5449c27e
diff --git a/dev-ruby/thor/thor-1.3.0.ebuild b/dev-ruby/thor/thor-1.3.0.ebuild
new file mode 100644
index 000000000000..2143223cbaa5
--- /dev/null
+++ b/dev-ruby/thor/thor-1.3.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2000-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_BINWRAP="thor"
+
+RUBY_FAKEGEM_GEMSPEC="thor.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple and efficient tool for building self-documenting command line utilities"
+HOMEPAGE="http://whatisthor.com/"
+SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux"
+IUSE="doc"
+
+# For initial target porting (new rubies), we can make these test deps
+# conditional with:
+# 1. USE_RUBY="<old rubies>" ruby_add_bdepend ...
+# 2. skip logic in each_ruby_test
+USE_RUBY="ruby31 ruby32" ruby_add_bdepend "
+ test? (
+ dev-ruby/childlabor
+ dev-ruby/webmock
+ )"
+
+all_ruby_prepare() {
+ # Remove rspec default options (as we might not have the last
+ # rspec).
+ rm .rspec || die
+
+ # Remove Bundler
+ #rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Thorfile || die
+
+ # Remove mandatory coverage collection using simplecov which is not
+ # packaged.
+ sed -i -e '/require "simplecov"/,/^end/ s:^:#:' spec/helper.rb || die
+
+ # Avoid a spec that requires UTF-8 support, so LANG=C still works,
+ # bug 430402
+ #sed -i -e '/uses maximum terminal width/,/end/ s:^:#:' spec/shell/basic_spec.rb || die
+
+ # Avoid specs depending on git, bug 724058
+ rm -f spec/quality_spec.rb || die
+
+ # Avoid currently broken readline specs (already fixed upstream)
+ rm -f spec/line_editor/readline_spec.rb spec/line_editor_spec.rb || die
+
+ # Avoid spec failing on whitespace difference in error message
+ sed -i -e '/raises an error for unknown switches/askip "whitespace differences"' spec/parser/options_spec.rb || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby33)
+ einfo "Skipping tests due to circular dependencies"
+ ;;
+ *)
+ RSPEC_VERSION=3 ruby-ng_rspec spec || die
+ ;;
+ esac
+}