summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2025-01-08 08:05:08 +0100
committerHans de Graaff <graaff@gentoo.org>2025-01-08 08:05:08 +0100
commit42415b5493545d4a0419f23843b9576fadecba58 (patch)
tree6dec19d7c7e3115d5fa3140580ab79f7381174e8 /dev-ruby
parentx11-wm/mutter: update minimum libdisplay-info version for live (only) (diff)
downloadgentoo-42415b5493545d4a0419f23843b9576fadecba58.tar.gz
gentoo-42415b5493545d4a0419f23843b9576fadecba58.tar.bz2
gentoo-42415b5493545d4a0419f23843b9576fadecba58.zip
dev-ruby/connection_pool: add 2.5.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/connection_pool/Manifest1
-rw-r--r--dev-ruby/connection_pool/connection_pool-2.5.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/connection_pool/Manifest b/dev-ruby/connection_pool/Manifest
index b6511dbbfed6..ae912b5ccedb 100644
--- a/dev-ruby/connection_pool/Manifest
+++ b/dev-ruby/connection_pool/Manifest
@@ -1 +1,2 @@
DIST connection_pool-2.4.1.tar.gz 11425 BLAKE2B 17aae4f8ce0461554eaddb4ee3535062608d75a29219ca44b1535f087db39429ddbc591d996c020b1fa557337e75bb15b0ac218e8b9f393f94e32e70ffe76800 SHA512 4529446de89d01adee28127807fe104ada683866bc61b60ee77acb718881aced982aa1a1e6e2330077d79ed3d77af199e8612a6dc08de4c40468ac4e3623b799
+DIST connection_pool-2.5.0.tar.gz 13120 BLAKE2B e914c07de63367d61e0f136ac95cb15cfb0595a232f2c72095b0ae97959f7d49a7dd1295e1509a3a21a43429e2f44a454e3e2146076cce683fdf6a0229e274d4 SHA512 ce43edb4dd25c050ad93d13ad0a4243bd8ed3234f3af3593b5301696fe31574b4ec20ffb6410caa459876ab4ed4d39d4767ebf57dd2970c25ad18672b42342ed
diff --git a/dev-ruby/connection_pool/connection_pool-2.5.0.ebuild b/dev-ruby/connection_pool/connection_pool-2.5.0.ebuild
new file mode 100644
index 000000000000..91a152103373
--- /dev/null
+++ b/dev-ruby/connection_pool/connection_pool-2.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33 ruby34"
+
+RUBY_FAKEGEM_GEMSPEC="connection_pool.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changes.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generic connection pooling for Ruby"
+HOMEPAGE="https://github.com/mperham/connection_pool"
+SRC_URI="https://github.com/mperham/connection_pool/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' connection_pool.gemspec || die
+ sed -i -e '/\(bundler\|standard\)/ s:^:#:' Rakefile || die
+ sed -i -e "s/gem 'minitest'/gem 'minitest', '~> 5.0'/" test/helper.rb || die
+}