summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-29 15:34:51 +0100
committerSam James <sam@gentoo.org>2023-03-29 15:34:51 +0100
commit5049291f5c1e139ab3d7a1928d129a9fc750b3d9 (patch)
treee0538c4988e81b807bc84153fe05aeb533515b8e /dev-ruby
parentRevert "dev-ruby/sass-rails: drop 5.0.8" (diff)
downloadgentoo-5049291f5c1e139ab3d7a1928d129a9fc750b3d9.tar.gz
gentoo-5049291f5c1e139ab3d7a1928d129a9fc750b3d9.tar.bz2
gentoo-5049291f5c1e139ab3d7a1928d129a9fc750b3d9.zip
Revert "dev-ruby/net-http-persistent: drop 3.1.0"
This reverts commit fc5f47afef9e7bd37e0e70ac2018dc470a8a8040. This is last-rited already so let's allow it to be removed naturally. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/net-http-persistent/Manifest1
-rw-r--r--dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/net-http-persistent/Manifest b/dev-ruby/net-http-persistent/Manifest
index 1300726e81aa..6cef2d4de01a 100644
--- a/dev-ruby/net-http-persistent/Manifest
+++ b/dev-ruby/net-http-persistent/Manifest
@@ -1 +1,2 @@
+DIST net-http-persistent-3.1.0.gem 31744 BLAKE2B fdd9c36ab5216c1cd1fe358207a689276e109845ac374ea16011469b6cb2b165115e78e701cce98c280e7f878c23d8016e75cac4508c7e579209012671b64101 SHA512 65b5afc4ad0729ec14b642e0e36363cecfff3dc25b26308d632866e93fed3eccfb83ce85da78f631553c6a1fe3ee834fcbc9d3681c85db6387463abbc30e60fa
DIST net-http-persistent-4.0.1.gem 27136 BLAKE2B b88151498c401cc20983c86859d7ef7ae3688ee12a5fcc69544d9716c3aeed55f4339d35ec08e9c0a6a16b4b4ab807d7155425c3056b9634185c255472ad93c5 SHA512 d3c86c9c58affac8cde1513dd899527406c0baafd3a620b80011e3babf51a4bfd6fb2bd8998fd9c4696d49aad2d014bdf666b9626e06fe4413cb4010f94e5e91
diff --git a/dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild b/dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild
new file mode 100644
index 000000000000..13fed6f70af6
--- /dev/null
+++ b/dev-ruby/net-http-persistent/net-http-persistent-3.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Manages persistent connections using Net::HTTP plus a speed fix for Ruby 1.8"
+HOMEPAGE="https://github.com/drbrain/net-http-persistent"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend ">=dev-ruby/connection_pool-2.2:0"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/hoe dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # avoid test with implicit dependency on net-http-pipeline which
+ # fails and is not tested upstream
+ sed -i -e '/net-http-pipeline not installed/ s/unless.*$//' test/test_net_http_persistent.rb || die
+}