summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-10-11 21:14:56 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-10-11 21:15:04 +0200
commit8f08acb8a82b8d6319b9fec7170ad582280fba47 (patch)
tree39f866248cf7e4ec7e7810e316f9226710800351 /dev-ruby
parentdev-lang/php: drop 8.0.29, 8.0.30 (diff)
downloadgentoo-8f08acb8a82b8d6319b9fec7170ad582280fba47.tar.gz
gentoo-8f08acb8a82b8d6319b9fec7170ad582280fba47.tar.bz2
gentoo-8f08acb8a82b8d6319b9fec7170ad582280fba47.zip
dev-ruby/mail: drop 2.7.1-r1, 2.7.1-r2
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/mail/Manifest1
-rw-r--r--dev-ruby/mail/files/mail-2.7.1-psych-4.patch122
-rw-r--r--dev-ruby/mail/mail-2.7.1-r1.ebuild32
-rw-r--r--dev-ruby/mail/mail-2.7.1-r2.ebuild37
4 files changed, 0 insertions, 192 deletions
diff --git a/dev-ruby/mail/Manifest b/dev-ruby/mail/Manifest
index ec9d7fecfb18..877403508ab3 100644
--- a/dev-ruby/mail/Manifest
+++ b/dev-ruby/mail/Manifest
@@ -1,4 +1,3 @@
-DIST mail-2.7.1-git.tar.gz 625251 BLAKE2B c1efbb259042155e983c1971fe9821eb0dd850089bd04cb0c74513f6f17dabf8ecc3155d9e5846ae657383f522872323f8fba37d51fba4318ac682d18a6d4c50 SHA512 17c601c86715135331f750048339a11a67a17f34486dbafa3ba7e9af9970d60927a2fa95c72a398418548df1fdf5addb2ed3afe9da7dff1f0bd949438726be1b
DIST mail-2.8.0-git.tar.gz 620136 BLAKE2B 4c115ddf92ef18c7889d391d264bf4c0be37be4849accf6e4778cc50317a4c0cd5f042c465f4f7862ca33e1de166b35bcb6d6e08e3fe44cce6aecbf1c1f9380e SHA512 ac60d72d16dd75fb5e8474900e069d5f711ce66340582a96d1f79ba582841cb82b212637053f45d1014997776ff411cbc8f9c19e06f024f6aa59b09c50c02583
DIST mail-2.8.0.1-git.tar.gz 620162 BLAKE2B 92a183df4cec63c194debb5fd1c5194f2fe8d909094f9b79c157c3c004574c78e8b2567c44a7f62f3a91af4689e7e2ca023768f005ff62998d0999a0d46e4bf3 SHA512 d2c84ffec336bb1967107641b741eef06238e37d68704024d3f037893e95fcf9501ffdb34f3f820e1f8df63b4057e0d329d09cd6a96281801ece6fb3d26f1a4d
DIST mail-2.8.1-git.tar.gz 621412 BLAKE2B f39c3087bf5d064fd9a96b93ccac2fd0060c53a53c900658e3907dce311aabba8136ce96bcd4937f5a9852ed3d046e1354c3c2757330d80f9b3d0542fc27cd12 SHA512 2c176361285b17b10ab3e518502b05ac582f033f81fc45df0b61bfcb5b645ea22139ef3abf67240adb27a39834dfee59bb0777c6de5448c2fe2e52d5dde3465a
diff --git a/dev-ruby/mail/files/mail-2.7.1-psych-4.patch b/dev-ruby/mail/files/mail-2.7.1-psych-4.patch
deleted file mode 100644
index ea3dff47910e..000000000000
--- a/dev-ruby/mail/files/mail-2.7.1-psych-4.patch
+++ /dev/null
@@ -1,122 +0,0 @@
-https://bugs.gentoo.org/835322
-
-https://github.com/mikel/mail/commit/a20fdd591bd5b1596983f5e1ee6ffed4e0b1f5f9
-https://sources.debian.org/patches/ruby-mail/2.7.1%2Bdfsg1-2/0001-Add-Mail-YAML-load-compatible-with-Psych-3.x-and-Psy.patch/
-
-From: =?utf-8?b?Sm9zZWYgxaBpbcOhbmVr?= <josef.simanek@gmail.com>
-Date: Sun, 4 Dec 2022 15:18:33 -0300
-Subject: Add Mail::YAML#load compatible with Psych 3.x and Psych 4.x.
-MIME-Version: 1.0
-Content-Type: text/plain; charset="utf-8"
-Content-Transfer-Encoding: 8bit
-
-Co-authored-by: Vít Ondruch <vondruch@redhat.com>
-Backported-by: Antonio Terceiro <terceiro@debian.org>
-Origin: https://github.com/mikel/mail/commit/a20fdd591bd5b1596983f5e1ee6ffed4e0b1f5f9
---- a/lib/mail/message.rb
-+++ b/lib/mail/message.rb
-@@ -1,6 +1,6 @@
- # encoding: utf-8
- # frozen_string_literal: true
--require "yaml"
-+require "mail/yaml"
-
- module Mail
- # The Message class provides a single point of access to all things to do with an
-@@ -1867,7 +1867,7 @@ module Mail
- end
-
- def self.from_yaml(str)
-- hash = YAML.load(str)
-+ hash = Mail::YAML.load(str)
- m = self.new(:headers => hash['headers'])
- hash.delete('headers')
- hash.each do |k,v|
---- /dev/null
-+++ b/lib/mail/yaml.rb
-@@ -0,0 +1,30 @@
-+require 'yaml'
-+
-+module Mail
-+ module YAML
-+ def self.load(yaml)
-+ permitted_classes = [
-+ Symbol,
-+
-+ Mail::Body,
-+
-+ # Delivery methods as listed in mail/configuration.rb
-+ Mail::SMTP,
-+ Mail::Sendmail,
-+ Mail::Exim,
-+ Mail::FileDelivery,
-+ Mail::SMTPConnection,
-+ Mail::TestMailer,
-+ Mail::LoggerDelivery,
-+
-+ Mail.delivery_method.class,
-+ ]
-+
-+ if Gem::Version.new(Psych::VERSION) >= Gem::Version.new('3.1.0.pre1')
-+ ::YAML.safe_load(yaml, :permitted_classes => permitted_classes)
-+ else
-+ ::YAML.safe_load(yaml, permitted_classes)
-+ end
-+ end
-+ end
-+end
---- a/spec/mail/message_spec.rb
-+++ b/spec/mail/message_spec.rb
-@@ -198,7 +198,7 @@ describe Mail::Message do
-
- it "should serialize the basic information to YAML" do
- yaml = @yaml_mail.to_yaml
-- yaml_output = YAML.load(yaml)
-+ yaml_output = Mail::YAML.load(yaml)
- expect(yaml_output['headers']['To']).to eq "someone@somewhere.com"
- expect(yaml_output['headers']['Cc']).to eq "someoneelse@somewhere.com"
- expect(yaml_output['headers']['Subject']).to eq "subject"
-@@ -216,7 +216,7 @@ describe Mail::Message do
- it "should serialize a Message with a custom delivery_handler" do
- @yaml_mail.delivery_handler = DeliveryAgent
- yaml = @yaml_mail.to_yaml
-- yaml_output = YAML.load(yaml)
-+ yaml_output = Mail::YAML.load(yaml)
- expect(yaml_output['delivery_handler']).to eq "DeliveryAgent"
- end
-
-@@ -228,7 +228,7 @@ describe Mail::Message do
-
- it "should not deserialize a delivery_handler that does not exist" do
- yaml = @yaml_mail.to_yaml
-- yaml_hash = YAML.load(yaml)
-+ yaml_hash = Mail::YAML.load(yaml)
- yaml_hash['delivery_handler'] = "NotARealClass"
- deserialized = Mail::Message.from_yaml(yaml_hash.to_yaml)
- expect(deserialized.delivery_handler).to be_nil
---- a/spec/mail/parts_list_spec.rb
-+++ b/spec/mail/parts_list_spec.rb
-@@ -89,6 +89,6 @@ describe "PartsList" do
-
- it "should have a round-tripping YAML serialization" do
- p = Mail::PartsList.new([1, 2])
-- expect(YAML.load(YAML.dump(p))).to eq(p)
-+ expect(Mail::YAML.load(YAML.dump(p))).to eq(p)
- end
- end
---- /dev/null
-+++ b/spec/mail/yaml_spec.rb
-@@ -0,0 +1,13 @@
-+# encoding: utf-8
-+# frozen_string_literal: true
-+require 'spec_helper'
-+
-+describe Mail::YAML do
-+
-+ describe "#load" do
-+
-+ it 'loads YAML' do
-+ expect(Mail::YAML.load('{}')).to eq({})
-+ end
-+ end
-+end
diff --git a/dev-ruby/mail/mail-2.7.1-r1.ebuild b/dev-ruby/mail/mail-2.7.1-r1.ebuild
deleted file mode 100644
index 67041aef5205..000000000000
--- a/dev-ruby/mail/mail-2.7.1-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.md"
-
-RUBY_FAKEGEM_GEMSPEC="mail.gemspec"
-
-inherit ruby-fakegem
-
-GITHUB_USER="mikel"
-
-DESCRIPTION="An email handling library"
-HOMEPAGE="https://github.com/mikel/mail"
-SRC_URI="https://github.com/${GITHUB_USER}/mail/archive/${PV}.tar.gz -> ${P}-git.tar.gz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/mini_mime-0.1.1"
-
-all_ruby_prepare() {
- rm Gemfile || die
- sed -i -e '/[Bb]undle/d' -e '6d' Rakefile || die "Unable to remove Bundler code."
-}
diff --git a/dev-ruby/mail/mail-2.7.1-r2.ebuild b/dev-ruby/mail/mail-2.7.1-r2.ebuild
deleted file mode 100644
index 2f47190243f9..000000000000
--- a/dev-ruby/mail/mail-2.7.1-r2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby27 ruby30 ruby31 ruby32"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.md"
-
-RUBY_FAKEGEM_GEMSPEC="mail.gemspec"
-
-inherit ruby-fakegem
-
-GITHUB_USER="mikel"
-
-DESCRIPTION="An email handling library"
-HOMEPAGE="https://github.com/mikel/mail"
-SRC_URI="https://github.com/${GITHUB_USER}/mail/archive/${PV}.tar.gz -> ${P}-git.tar.gz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/mini_mime-0.1.1"
-
-PATCHES=(
- "${FILESDIR}"/${P}-psych-4.patch
-)
-
-all_ruby_prepare() {
- rm Gemfile || die
- sed -i -e '/[Bb]undle/d' -e '6d' Rakefile || die "Unable to remove Bundler code."
-}