summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-12-12 14:55:50 +0100
committerHans de Graaff <graaff@gentoo.org>2023-12-12 15:06:48 +0100
commitc12495cd4ea63bc9a58491d687be67f1fe2c0fa0 (patch)
tree11c769944761ac0d0a4e8656f9c9cfd8ff904555 /dev-ruby
parentdev-cpp/abseil-cpp: drop 20200923.3 (diff)
downloadgentoo-c12495cd4ea63bc9a58491d687be67f1fe2c0fa0.tar.gz
gentoo-c12495cd4ea63bc9a58491d687be67f1fe2c0fa0.tar.bz2
gentoo-c12495cd4ea63bc9a58491d687be67f1fe2c0fa0.zip
dev-ruby/puppet_forge: add 5.0.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/puppet_forge/Manifest1
-rw-r--r--dev-ruby/puppet_forge/puppet_forge-5.0.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/puppet_forge/Manifest b/dev-ruby/puppet_forge/Manifest
index d14d7948fecf..d4bcf25582ce 100644
--- a/dev-ruby/puppet_forge/Manifest
+++ b/dev-ruby/puppet_forge/Manifest
@@ -2,3 +2,4 @@ DIST puppet_forge-3.2.0.gem 771072 BLAKE2B dd304297aa65dc0f36f837e27abf255a0474f
DIST puppet_forge-4.1.0.gem 772096 BLAKE2B 2d6f0af8baa067f79eb113f0de9596c562cdda678587fdd1cb14960535ded5fdbafb2b5ff0ebbd6ae676fb10d766f949b599b43c9b04dac55fc28b8163ef1383 SHA512 f752069d8b1998b3d27745abe3e6ad87a24ef614a68b52af2235a0587f98c69d8e39d2637640431f64d5c91ce468e3a2e2452b6ce8fa91d83b00c20ad047ae33
DIST puppet_forge-5.0.1.gem 774144 BLAKE2B 2770c0609d93b3518017b36344025dbd7ab51360fea4af8f7ee610f4117f31de25698ad192ab00755564f0a57d9e6b041a7568440dbc5b47e2830a8cb00cd8f8 SHA512 3d29c166e1c22d7b4d45251866fbd8e6756a3026be5e17b1abe8cd6baaa7af4ddde7f2d07b75c21c5716c545cc6df82e36b1070a43a3d3c363214d3a5102843b
DIST puppet_forge-5.0.2.gem 774144 BLAKE2B 6b01872246dc4791f78cefcb9df213df5768df483c8fac4bad12ddf358210ecb2b827ad129790e37d636ce4d7d0abb381097ffd2ee518a8472b067f5ba6de0a5 SHA512 861ac99a3e5234a8555fe37329b621135140d41c0fbad69648f56b901b10254d0474494c64525ebc4a0b730dfa91e9889ea4cf6ca7e2d5e40453221dd2e7370d
+DIST puppet_forge-5.0.3.gem 776704 BLAKE2B 2ea9e6a17fb5231629551b4dc2ca02f4843d67ded114f43a9891dba6a7ce03ab0b1b8ed38b434e8bcdfc73e940a263964a8254ba18493a137bd14600c3251a18 SHA512 17cb9aaf9c911608b90f2eb3e2561d94bffdfec559cb22bb0fa53d799f4a53f77c332ec261270135a924a4996d35b39945a4a94f7163b44dd9bb10f6ea72366f
diff --git a/dev-ruby/puppet_forge/puppet_forge-5.0.3.ebuild b/dev-ruby/puppet_forge/puppet_forge-5.0.3.ebuild
new file mode 100644
index 000000000000..642b012de688
--- /dev/null
+++ b/dev-ruby/puppet_forge/puppet_forge-5.0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tools to access Forge API information on Modules, Users, and Releases"
+HOMEPAGE="https://github.com/puppetlabs/forge-ruby"
+
+LICENSE="Apache-2.0"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${PN}-5.0.1-typhoeus.patch" )
+
+ruby_add_rdepend "
+ dev-ruby/faraday:2
+ >=dev-ruby/faraday-follow_redirects-0.3.0:0.3
+ dev-ruby/minitar
+ =dev-ruby/semantic_puppet-1*
+"
+
+all_ruby_prepare() {
+ # Avoid integration and user specs since they all require network access
+ rm -rf spec/integration spec/unit/forge/v3/user_spec.rb || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}