summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-01-28 21:45:53 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-01-28 21:59:08 +0100
commita36244ed3e7c2a462a0adf878203ae4a6fa2fd73 (patch)
tree0e322097d97cc9c0f8e320c78e074cf91086b2cb /dev-scheme/gambit
parentdev-python/gst-python: add python 3.10 (diff)
downloadgentoo-a36244ed3e7c2a462a0adf878203ae4a6fa2fd73.tar.gz
gentoo-a36244ed3e7c2a462a0adf878203ae4a6fa2fd73.tar.bz2
gentoo-a36244ed3e7c2a462a0adf878203ae4a6fa2fd73.zip
dev-scheme/gambit: drop 4.8.8-r1
4.8.8-r1 & 4.8.8-r2 are the same, except r1 has different formatting of DEPEND and unstable KEYWORDS Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-scheme/gambit')
-rw-r--r--dev-scheme/gambit/gambit-4.8.8-r2.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-scheme/gambit/gambit-4.8.8-r2.ebuild b/dev-scheme/gambit/gambit-4.8.8-r2.ebuild
deleted file mode 100644
index acb5d61f3959..000000000000
--- a/dev-scheme/gambit/gambit-4.8.8-r2.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit elisp-common
-
-MY_PV="${PV//./_}"
-MY_P="${PN}-v${MY_PV}"
-
-DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter"
-HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
-SRC_URI="http://www-labs.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
-
-LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="ssl? (
- dev-libs/openssl:0=
- )"
-DEPEND="
- ${RDEPEND}
- emacs? ( >=app-editors/emacs-23.1:* )
-"
-
-SITEFILE="50gambit-gentoo.el"
-
-S="${WORKDIR}/${MY_P}" #-devel
-
-IUSE="emacs ssl static"
-
-src_configure() {
- econf \
- $(use_enable !static shared) \
- $(use_enable ssl openssl) \
- --enable-gnu-gcc-specific-options \
- --enable-gnu-gcc-no-strict-aliasing \
- --enable-single-host \
- --disable-absolute-shared-libs \
- --enable-type-checking
-}
-
-src_compile() {
- emake bootstrap
-
- if use emacs; then
- elisp-compile misc/*.el || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- keepdir /usr/share/"${MY_PN}"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}