summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-05-03 09:07:11 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-05-03 10:14:40 +0100
commita0c80affad8c87d4162f8a7e7c8671b4695d2c04 (patch)
tree7ac2438932e83da688ebb63363dfa79bc8c885d3 /dev-scheme/guile-git/guile-git-0.2.0.ebuild
parentsys-kernel/vanilla-sources: Automated version bump to 3.16.66 - remove old. (diff)
downloadgentoo-a0c80affad8c87d4162f8a7e7c8671b4695d2c04.tar.gz
gentoo-a0c80affad8c87d4162f8a7e7c8671b4695d2c04.tar.bz2
gentoo-a0c80affad8c87d4162f8a7e7c8671b4695d2c04.zip
dev-scheme/guile-git: bump up to release 0.2.0 version
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-scheme/guile-git/guile-git-0.2.0.ebuild')
-rw-r--r--dev-scheme/guile-git/guile-git-0.2.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-scheme/guile-git/guile-git-0.2.0.ebuild b/dev-scheme/guile-git/guile-git-0.2.0.ebuild
new file mode 100644
index 000000000000..e7d04b77a493
--- /dev/null
+++ b/dev-scheme/guile-git/guile-git-0.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Guile bindings of git"
+HOMEPAGE="https://gitlab.com/guile-git/guile-git"
+SRC_URI="https://gitlab.com/guile-git/guile-git/uploads/160f6a36c1be8d4fc1990a193081a04d/guile-git-${PV}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-scheme/guile-2.0.11:=
+ dev-scheme/bytestructures
+ dev-libs/libgit2:=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # guile is trying to avoid recompilation by checking if file
+ # /usr/lib64/guile/2.2/site-ccache/<foo>
+ # is newer than
+ # <foo>
+ # In case it is instead of using <foo> guile
+ # loads system one (from potentially older version of package).
+ # To work it around we bump last modification timestamp of
+ # '*.scm' files.
+ find "${S}" -name "*.scm" -exec touch {} + || die
+}
+
+
+src_test() {
+ emake check VERBOSE=1
+}