summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/mysqltcl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/mysqltcl')
-rw-r--r--dev-tcltk/mysqltcl/Manifest1
-rw-r--r--dev-tcltk/mysqltcl/files/mysqltcl-3.05-ldflags.patch16
-rw-r--r--dev-tcltk/mysqltcl/metadata.xml5
-rw-r--r--dev-tcltk/mysqltcl/mysqltcl-3.05.ebuild35
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-tcltk/mysqltcl/Manifest b/dev-tcltk/mysqltcl/Manifest
new file mode 100644
index 000000000000..5649f4b8451f
--- /dev/null
+++ b/dev-tcltk/mysqltcl/Manifest
@@ -0,0 +1 @@
+DIST mysqltcl-3.05.tar.gz 198755 SHA256 e2346aee4b99b2d91b552718e4be8ec8c4fc4bbbfe12430e4041e9e13d27a245 SHA512 14e0196b2fce08d97b085bcf25357a72797e9566578a6c0674a76e4402a704b43919b1ce8360d55719a6f2a36c6f68f3762dd23a9f737b7cf9f6537a00acb7ef WHIRLPOOL c2dc4d1441c4092f6d12fa2a1890d6dbda4eb822ec7b87106586e9980d331b04f825e4ac9ad08a8b9dd0604fe3547bf5f73251e27d793e73e0f3213114717620
diff --git a/dev-tcltk/mysqltcl/files/mysqltcl-3.05-ldflags.patch b/dev-tcltk/mysqltcl/files/mysqltcl-3.05-ldflags.patch
new file mode 100644
index 000000000000..5aa440332153
--- /dev/null
+++ b/dev-tcltk/mysqltcl/files/mysqltcl-3.05-ldflags.patch
@@ -0,0 +1,16 @@
+ Makefile.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 0552d56..e32a0b4 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -107,7 +107,7 @@ OBJEXT = @OBJEXT@
+ RANLIB = @RANLIB@
+ RANLIB_STUB = @RANLIB_STUB@
+ SHLIB_CFLAGS = @SHLIB_CFLAGS@
+-SHLIB_LD = @SHLIB_LD@
++SHLIB_LD = @SHLIB_LD@ $(LDFLAGS)
+ SHLIB_LD_LIBS = @SHLIB_LD_LIBS@ @MYSQL_LIBS@
+ STLIB_LD = @STLIB_LD@
+ #TCL_DEFS = @TCL_DEFS@
diff --git a/dev-tcltk/mysqltcl/metadata.xml b/dev-tcltk/mysqltcl/metadata.xml
new file mode 100644
index 000000000000..716e7d4301bd
--- /dev/null
+++ b/dev-tcltk/mysqltcl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>mysql</herd>
+</pkgmetadata>
diff --git a/dev-tcltk/mysqltcl/mysqltcl-3.05.ebuild b/dev-tcltk/mysqltcl/mysqltcl-3.05.ebuild
new file mode 100644
index 000000000000..17beab1a505f
--- /dev/null
+++ b/dev-tcltk/mysqltcl/mysqltcl-3.05.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils multilib
+
+DESCRIPTION="TCL MySQL Interface"
+HOMEPAGE="http://www.xdobry.de/mysqltcl/"
+SRC_URI="http://www.xdobry.de/mysqltcl/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+DEPEND="
+ dev-lang/tcl:0
+ >=virtual/mysql-4.1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ sed -i 's/-pipe//g;s/-O2//g;s/-fomit-frame-pointer//g' configure || die
+}
+
+src_configure() {
+ econf --with-mysql-lib=/usr/$(get_libdir)/mysql
+}
+
+src_install() {
+ default
+ dohtml doc/mysqltcl.html
+}