summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-01-17 21:49:19 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-01-17 21:49:19 +0100
commit4af419b7a066f4cb06c86cd8c70274e93262abeb (patch)
tree2c7ed04f46a3c358ba866d678826511aea8b8b5d /dev-tcltk/tktable
parentdev-tcltk/tkimg: fix sed warning (diff)
downloadgentoo-4af419b7a066f4cb06c86cd8c70274e93262abeb.tar.gz
gentoo-4af419b7a066f4cb06c86cd8c70274e93262abeb.tar.bz2
gentoo-4af419b7a066f4cb06c86cd8c70274e93262abeb.zip
dev-tcltk/tktable: update EAPI 6 -> 8
Closes: https://bugs.gentoo.org/880585 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk/tktable')
-rw-r--r--dev-tcltk/tktable/files/tktable-2.10-parallelMake.patch12
-rw-r--r--dev-tcltk/tktable/tktable-2.10-r1.ebuild33
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-tcltk/tktable/files/tktable-2.10-parallelMake.patch b/dev-tcltk/tktable/files/tktable-2.10-parallelMake.patch
new file mode 100644
index 000000000000..534a0a83b901
--- /dev/null
+++ b/dev-tcltk/tktable/files/tktable-2.10-parallelMake.patch
@@ -0,0 +1,12 @@
+--- a/Makefile.in 2023-01-17 21:41:13.532754760 +0100
++++ b/Makefile.in 2023-01-17 21:41:35.153416999 +0100
+@@ -189,7 +189,8 @@
+ # for the BINARIES that you specified above have already been done.
+ #========================================================================
+
+-all: binaries libraries doc
++all: tkTable.tcl.h
++ $(MAKE) binaries libraries doc
+
+ #========================================================================
+ # The binaries target builds executable programs, Windows .dll's, unix
diff --git a/dev-tcltk/tktable/tktable-2.10-r1.ebuild b/dev-tcltk/tktable/tktable-2.10-r1.ebuild
new file mode 100644
index 000000000000..7fa28703fe02
--- /dev/null
+++ b/dev-tcltk/tktable/tktable-2.10-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="Tktable${PV}"
+
+DESCRIPTION="full-featured 2D table widget"
+HOMEPAGE="http://tktable.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tktable/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="amd64 ppc x86"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/tk-8.0:="
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+HTML_DOCS=( doc/tkTable.html )
+DOCS=( ChangeLog README.txt release.txt )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-parallelMake.patch
+)
+
+src_prepare() {
+ default
+ sed -e '/^install:/{s: install-doc::}' \
+ -e '/^PKG_EXTRA_FILES/{s:=.*:=:}' -i Makefile.in || die
+}