summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-12-06 00:50:36 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2019-12-06 00:50:54 +0100
commit8c484e328c2f74cc94eb1623ea112813013013ab (patch)
treed8b3f1ca0b4230fe344dc297e1d9d5fdf9b28961 /dev-tex/dot2tex/dot2tex-2.11.3.ebuild
parentpackage.mask: unmask trackma, no longer needs py2 (diff)
downloadgentoo-8c484e328c2f74cc94eb1623ea112813013013ab.tar.gz
gentoo-8c484e328c2f74cc94eb1623ea112813013013ab.tar.bz2
gentoo-8c484e328c2f74cc94eb1623ea112813013013ab.zip
dev-tex/dot2tex: 2.11.3 bump
Ebuild update and add python 3 support Closes: https://bugs.gentoo.org/699956 Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'dev-tex/dot2tex/dot2tex-2.11.3.ebuild')
-rw-r--r--dev-tex/dot2tex/dot2tex-2.11.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-tex/dot2tex/dot2tex-2.11.3.ebuild b/dev-tex/dot2tex/dot2tex-2.11.3.ebuild
new file mode 100644
index 000000000000..2ea47959d682
--- /dev/null
+++ b/dev-tex/dot2tex/dot2tex-2.11.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7})
+
+inherit distutils-r1
+
+DESCRIPTION="A Graphviz to LaTeX converter"
+HOMEPAGE="https://dot2tex.readthedocs.org/ https://github.com/kjellmf/dot2tex"
+SRC_URI="https://github.com/kjellmf/dot2tex/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="doc examples"
+
+DEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/pydot[${PYTHON_USEDEP}]
+ media-gfx/graphviz"
+DEPEND="${DEPEND}
+ doc? ( dev-python/sphinx )"
+
+python_compile_all() {
+ if use doc ; then
+ cd "${S}/docs"
+ emake html
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dodoc -r docs/_build/html
+ fi
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}