summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2021-02-11 10:53:18 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2021-02-11 10:53:18 -0500
commitf193eed645e48a68f25ec4ee08b6a9b8af82f106 (patch)
tree03efb2cc1a7a4e318e24706bf22c10c1c8ecd216 /dev-tex/latexmk/latexmk-470b.ebuild
parentapp-crypt/mit-krb5: bump to 1.19 (diff)
downloadgentoo-f193eed645e48a68f25ec4ee08b6a9b8af82f106.tar.gz
gentoo-f193eed645e48a68f25ec4ee08b6a9b8af82f106.tar.bz2
gentoo-f193eed645e48a68f25ec4ee08b6a9b8af82f106.zip
dev-tex/latexmk: Bump to 470b
Closes: https://bugs.gentoo.org/769953 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-tex/latexmk/latexmk-470b.ebuild')
-rw-r--r--dev-tex/latexmk/latexmk-470b.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-tex/latexmk/latexmk-470b.ebuild b/dev-tex/latexmk/latexmk-470b.ebuild
new file mode 100644
index 000000000000..bc127260d7d5
--- /dev/null
+++ b/dev-tex/latexmk/latexmk-470b.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+DESCRIPTION="Perl script for automatically building LaTeX documents"
+HOMEPAGE="https://personal.psu.edu/~jcc8/software/latexmk/
+ https://ctan.org/pkg/latexmk/"
+SRC_URI="https://personal.psu.edu/~jcc8/software/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ newbin latexmk.pl latexmk
+ doman latexmk.1
+ dodoc CHANGES README latexmk.pdf latexmk.txt
+ dodoc -r example_rcfiles extra-scripts
+ newbashcomp "${FILESDIR}"/completion.bash-2 ${PN}
+}