summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2023-01-13 11:04:17 +0100
committerSam James <sam@gentoo.org>2023-01-13 10:22:34 +0000
commite6371538947cff10c0d6dba0f36dd93af9b555f9 (patch)
tree35baaa0536dc6a2c187973cd075ef14f227a2c03 /dev-util/bpftool
parentsci-mathematics/gimps: Stabilize 30.8.17 amd64, #890640 (diff)
downloadgentoo-e6371538947cff10c0d6dba0f36dd93af9b555f9.tar.gz
gentoo-e6371538947cff10c0d6dba0f36dd93af9b555f9.tar.bz2
gentoo-e6371538947cff10c0d6dba0f36dd93af9b555f9.zip
dev-util/bftool: fix build with clang+ssp
Closes: https://bugs.gentoo.org/890638 Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Closes: https://github.com/gentoo/gentoo/pull/29086 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/bpftool')
-rw-r--r--dev-util/bpftool/bpftool-5.19.12.ebuild1
-rw-r--r--dev-util/bpftool/bpftool-6.0.12.ebuild5
-rw-r--r--dev-util/bpftool/files/5.19.12-no-stack-protector.patch14
-rw-r--r--dev-util/bpftool/files/6.0.12-no-stack-protector.patch14
4 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/bpftool/bpftool-5.19.12.ebuild b/dev-util/bpftool/bpftool-5.19.12.ebuild
index aa4096be5d13..49cf78ab56a8 100644
--- a/dev-util/bpftool/bpftool-5.19.12.ebuild
+++ b/dev-util/bpftool/bpftool-5.19.12.ebuild
@@ -92,6 +92,7 @@ src_prepare() {
# Used `git format-patch 00b32625982e0c796f0abb8effcac9c05ef55bd3...600b7b26c07a070d0153daa76b3806c1e52c9e00`
# bug #868123
eapply "${WORKDIR}"/perf-5.19-binutils-2.39-patches
+ eapply "${FILESDIR}"/${PV}-no-stack-protector.patch
popd || die
# dev-python/docutils installs rst2man.py, not rst2man
diff --git a/dev-util/bpftool/bpftool-6.0.12.ebuild b/dev-util/bpftool/bpftool-6.0.12.ebuild
index 35996f352094..5e3c53bae36d 100644
--- a/dev-util/bpftool/bpftool-6.0.12.ebuild
+++ b/dev-util/bpftool/bpftool-6.0.12.ebuild
@@ -86,6 +86,11 @@ src_prepare() {
popd || die
fi
+ pushd "${S_K}" >/dev/null || die
+ # bug #890638
+ eapply "${FILESDIR}"/${PV}-no-stack-protector.patch
+ popd || die
+
# dev-python/docutils installs rst2man.py, not rst2man
sed -i -e 's/rst2man/rst2man.py/g' Documentation/Makefile || die
}
diff --git a/dev-util/bpftool/files/5.19.12-no-stack-protector.patch b/dev-util/bpftool/files/5.19.12-no-stack-protector.patch
new file mode 100644
index 000000000000..c9ae115ac20d
--- /dev/null
+++ b/dev-util/bpftool/files/5.19.12-no-stack-protector.patch
@@ -0,0 +1,14 @@
+
+https://bugs.gentoo.org/890638
+
+--- a/tools/bpf/bpftool/Makefile 2022-12-11 23:15:18.000000000 +0100
++++ b/tools/bpf/bpftool/Makefile 2023-01-13 10:32:09.615048492 +0100
+@@ -187,7 +187,7 @@ $(OUTPUT)%.bpf.o: skeleton/%.bpf.c $(OUT
+ -I$(or $(OUTPUT),.) \
+ -I$(srctree)/tools/include/uapi/ \
+ -I$(LIBBPF_BOOTSTRAP_INCLUDE) \
+- -g -O2 -Wall -target bpf -c $< -o $@
++ -g -O2 -Wall -fno-stack-protector -target bpf -c $< -o $@
+ $(Q)$(LLVM_STRIP) -g $@
+
+ $(OUTPUT)%.skel.h: $(OUTPUT)%.bpf.o $(BPFTOOL_BOOTSTRAP)
diff --git a/dev-util/bpftool/files/6.0.12-no-stack-protector.patch b/dev-util/bpftool/files/6.0.12-no-stack-protector.patch
new file mode 100644
index 000000000000..c9ae115ac20d
--- /dev/null
+++ b/dev-util/bpftool/files/6.0.12-no-stack-protector.patch
@@ -0,0 +1,14 @@
+
+https://bugs.gentoo.org/890638
+
+--- a/tools/bpf/bpftool/Makefile 2022-12-11 23:15:18.000000000 +0100
++++ b/tools/bpf/bpftool/Makefile 2023-01-13 10:32:09.615048492 +0100
+@@ -187,7 +187,7 @@ $(OUTPUT)%.bpf.o: skeleton/%.bpf.c $(OUT
+ -I$(or $(OUTPUT),.) \
+ -I$(srctree)/tools/include/uapi/ \
+ -I$(LIBBPF_BOOTSTRAP_INCLUDE) \
+- -g -O2 -Wall -target bpf -c $< -o $@
++ -g -O2 -Wall -fno-stack-protector -target bpf -c $< -o $@
+ $(Q)$(LLVM_STRIP) -g $@
+
+ $(OUTPUT)%.skel.h: $(OUTPUT)%.bpf.o $(BPFTOOL_BOOTSTRAP)