summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2021-06-20 10:26:57 -0400
committerBrian Dolbec <dolsen@gentoo.org>2021-06-20 12:04:28 -0400
commit2434579ecd034cebbf4a6173d0ef4e01ce5deeda (patch)
treef19f08f3e2eab619b0dbdd64b9f94001ee023fda /dev-util/buildbot-pkg/buildbot-pkg-3.2.0.ebuild
parentmedia-gfx/imagemagick: copy stable keywords (diff)
downloadgentoo-2434579ecd034cebbf4a6173d0ef4e01ce5deeda.tar.gz
gentoo-2434579ecd034cebbf4a6173d0ef4e01ce5deeda.tar.bz2
gentoo-2434579ecd034cebbf4a6173d0ef4e01ce5deeda.zip
dev-util/buildbot-pkg: Version bump to 3.2.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-pkg/buildbot-pkg-3.2.0.ebuild')
-rw-r--r--dev-util/buildbot-pkg/buildbot-pkg-3.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/buildbot-pkg/buildbot-pkg-3.2.0.ebuild b/dev-util/buildbot-pkg/buildbot-pkg-3.2.0.ebuild
new file mode 100644
index 000000000000..03b7f005df6e
--- /dev/null
+++ b/dev-util/buildbot-pkg/buildbot-pkg-3.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="BuildBot common www build tools for packaging releases"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-pkg/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+# No real integration tests for this pkg.
+# all tests are related to making releases and final checks for distribution
+
+S=${WORKDIR}/${MY_P}