summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2024-10-14 23:46:26 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-10-18 10:05:16 +0300
commit53aeecf0dddc180df33e95302b308ab2eb94f02d (patch)
tree50ab6db9afefad8b115d34c6619ea734e597b275 /dev-util/buildbot-react-grid-view
parentdev-util/buildbot-react-console-view: add 3.11.9 (diff)
downloadgentoo-53aeecf0dddc180df33e95302b308ab2eb94f02d.tar.gz
gentoo-53aeecf0dddc180df33e95302b308ab2eb94f02d.tar.bz2
gentoo-53aeecf0dddc180df33e95302b308ab2eb94f02d.zip
dev-util/buildbot-react-grid-view: add 3.11.9
Signed-off-by: Magnus Granberg <zorry@gentoo.org> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-react-grid-view')
-rw-r--r--dev-util/buildbot-react-grid-view/Manifest1
-rw-r--r--dev-util/buildbot-react-grid-view/buildbot-react-grid-view-3.11.9.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/buildbot-react-grid-view/Manifest b/dev-util/buildbot-react-grid-view/Manifest
index fa4e0fac5976..775f1b023f4c 100644
--- a/dev-util/buildbot-react-grid-view/Manifest
+++ b/dev-util/buildbot-react-grid-view/Manifest
@@ -1,2 +1,3 @@
DIST buildbot-react-grid-view-3.11.0.tar.gz 9952 BLAKE2B c15b03994cb52293d875d22bb4e656e78d257d69e84f3790dadba9fa0f6c14e2c4ed59ec1e44ce4bbe09ec530f55dbf1f7a25dbcfe9af1a7a76d061281836a96 SHA512 4d264821485fd970b9e37673d5bf80886549cc948cd8122ba82972861c677f76a7b8b9afaa5162436b8c8e0e318196aa81594ef3b8755097d6e2e1d05d01befa
DIST buildbot-react-grid-view-3.11.1.tar.gz 9953 BLAKE2B 5f679d5a96355d5994b5507e894ee0bfa8012d4594de4fc04c722e11e34a2b2f11770a9bf50563e5a08cbe7528c94e4f985ffe4dea4c2c6bd49c8a18966f3d45 SHA512 8fd61137e9c959ca09c18d8dcfaad2c5137e0de33b1faa9a0a1cf7240e95f640a03d848bf04766b2e4a792c7b6d54f24038af20750a3afcae154b471a7fe4ac4
+DIST buildbot_react_grid_view-3.11.9.tar.gz 9848 BLAKE2B 36320e4caa4aed83bed04bc5ba7f57f7405d949a9a35d91c5f040104c57cf432621d79bad637607e28f1f8dde39e4ec7c03ce55d01bc736641c4e5d7c67e166b SHA512 34034a3f86db2eb31f75ba00336606e6d244d040982dbd943a45a05746e671fa488bebcdc334e3fc5dc11c6b14f726c276ec92cfac1a94b7a36056d2b11e3b2a
diff --git a/dev-util/buildbot-react-grid-view/buildbot-react-grid-view-3.11.9.ebuild b/dev-util/buildbot-react-grid-view/buildbot-react-grid-view-3.11.9.ebuild
new file mode 100644
index 000000000000..8ed172523167
--- /dev/null
+++ b/dev-util/buildbot-react-grid-view/buildbot-react-grid-view-3.11.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{10..12} )
+PYPI_PN=${PN/-react-grid-/_react_grid_}
+inherit distutils-r1 pypi
+
+DESCRIPTION="BuildBot react based grid view web interface"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-react-grid-view/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-react-${PV}[${PYTHON_USEDEP}]
+"