summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2021-06-20 10:31:20 -0400
committerBrian Dolbec <dolsen@gentoo.org>2021-06-20 12:04:31 -0400
commitda7cb94580810496840c55c7c1ffc25550bc9c84 (patch)
tree473ad0bd916ed2c62b595d1f42fb7c362c6e15ca /dev-util/buildbot-waterfall-view/buildbot-waterfall-view-3.2.0.ebuild
parentdev-util/buildbot-grid-view: Version bump to 3.2.0 (diff)
downloadgentoo-da7cb94580810496840c55c7c1ffc25550bc9c84.tar.gz
gentoo-da7cb94580810496840c55c7c1ffc25550bc9c84.tar.bz2
gentoo-da7cb94580810496840c55c7c1ffc25550bc9c84.zip
dev-util/buildbot-waterfall-view: Version bump to 3.2.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-waterfall-view/buildbot-waterfall-view-3.2.0.ebuild')
-rw-r--r--dev-util/buildbot-waterfall-view/buildbot-waterfall-view-3.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/buildbot-waterfall-view/buildbot-waterfall-view-3.2.0.ebuild b/dev-util/buildbot-waterfall-view/buildbot-waterfall-view-3.2.0.ebuild
new file mode 100644
index 000000000000..c2a121241d3d
--- /dev/null
+++ b/dev-util/buildbot-waterfall-view/buildbot-waterfall-view-3.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Buildbot waterfall-view plugin"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-waterfall-view/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+IUSE=""
+
+RDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"