summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2023-08-24 16:13:42 -0700
committerBrian Dolbec <dolsen@gentoo.org>2023-08-24 16:33:00 -0700
commit445038f151894f63bd2c24079bf6e54422b3bf4c (patch)
tree94d960f7c073e4c2e294592247f6227b295f5536 /dev-util/buildbot-worker
parentdev-util/buildbot-wsgi-dashboards: add 3.9.0 (diff)
downloadgentoo-445038f151894f63bd2c24079bf6e54422b3bf4c.tar.gz
gentoo-445038f151894f63bd2c24079bf6e54422b3bf4c.tar.bz2
gentoo-445038f151894f63bd2c24079bf6e54422b3bf4c.zip
dev-util/buildbot-worker:
Update 9999 ebuild (sort deps) Add Zorry to maintainers Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-worker')
-rw-r--r--dev-util/buildbot-worker/Manifest1
-rw-r--r--dev-util/buildbot-worker/buildbot-worker-3.9.0.ebuild137
-rw-r--r--dev-util/buildbot-worker/buildbot-worker-9999.ebuild4
-rw-r--r--dev-util/buildbot-worker/metadata.xml4
4 files changed, 144 insertions, 2 deletions
diff --git a/dev-util/buildbot-worker/Manifest b/dev-util/buildbot-worker/Manifest
index aec8d3312aff..5f1865d7aa29 100644
--- a/dev-util/buildbot-worker/Manifest
+++ b/dev-util/buildbot-worker/Manifest
@@ -1 +1,2 @@
DIST buildbot-worker-3.6.1.tar.gz 120224 BLAKE2B 010893b7b4e5710654299b2541c4cdcdad47b3b763dbc7e2336e5480c841908e04d8350c7cb42edd9ea99d16fd26f36a524a6d6bec8c0f933665a02ded369f89 SHA512 f1e3bf7c0da2f31dd446dc16487e32fddaecc0c2f9c17c469146707322a3d7bb2cc77db4f6145c62530bce58dd61aa19e008e944a7f39a17dc66f1317ee26e1b
+DIST buildbot-worker-3.9.0.tar.gz 125913 BLAKE2B e053cd150cf21cc0e5dfb2d49c186c49d340670429b760ce9f697aa97a245d0e6a12f0ea84eb1256a610891042096877c89244b1f2862bf74160502170f9124c SHA512 08b74d6f019ca85f65c598a34c81bc47fdf873abad17205072788d938fcd5450f80aa6ca9d324edc01893947f4ac8e2968889dd73be854a82b4ea54e4730613b
diff --git a/dev-util/buildbot-worker/buildbot-worker-3.9.0.ebuild b/dev-util/buildbot-worker/buildbot-worker-3.9.0.ebuild
new file mode 100644
index 000000000000..479a08e9fdd4
--- /dev/null
+++ b/dev-util/buildbot-worker/buildbot-worker-3.9.0.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+inherit readme.gentoo-r1 systemd distutils-r1 pypi
+
+DESCRIPTION="BuildBot Worker (slave) Daemon"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-worker/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~riscv ~sparc ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ acct-user/buildbot
+ !<dev-util/buildbot-1.0.0
+ >=dev-python/autobahn-0.16.0[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+DOC_CONTENTS="The \"buildbot\" user and the \"buildbot_worker\" init script has been added
+to support starting buildbot_worker through Gentoo's init system. To use this,
+execute \"emerge --config =${CATEGORY}/${PF}\" to create a new instance.
+Set up your build worker following the documentation, make sure the
+resulting directories are owned by the \"buildbot\" user and point
+\"${ROOT}/etc/conf.d/buildbot_worker.myinstance\" at the right location.
+The scripts can run as a different user if desired."
+
+src_prepare() {
+ # Remove shipped windows start script
+ sed -e "/'buildbot_worker_windows_service=buildbot_worker.scripts.windows_service:HandleCommandLine',/d" \
+ -i setup.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" -m twisted.trial buildbot_worker || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+
+ distutils-r1_python_install_all
+
+ doman docs/buildbot-worker.1
+
+ newconfd "${FILESDIR}/buildbot_worker.confd2" buildbot_worker
+ newinitd "${FILESDIR}/buildbot_worker.initd2" buildbot_worker
+ systemd_dounit "${FILESDIR}/buildbot_worker.target"
+ systemd_newunit "${FILESDIR}/buildbot_worker_at.service" "buildbot_worker@.service"
+ systemd_install_serviced "${FILESDIR}/buildbot_worker_at.service.conf" "buildbot_worker@.service"
+
+ dodir /var/lib/buildbot_worker
+ cp "${FILESDIR}/buildbot.tac.sample" "${D}/var/lib/buildbot_worker"|| die "Install failed!"
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ ewarn
+ ewarn "More than one instance of a buildbot_worker can be run simultaneously."
+ ewarn " Note that \"BASEDIR\" in the buildbot_worker configuration file"
+ ewarn "is now the common base directory for all instances. If you are migrating from an older"
+ ewarn "version, make sure that you copy the current contents of \"BASEDIR\" to a subdirectory."
+ ewarn "The name of the subdirectory corresponds to the name of the buildbot_worker instance."
+ ewarn "In order to start the service running OpenRC-based systems need to link to the init file:"
+ ewarn " ln --symbolic --relative /etc/init.d/buildbot_worker /etc/init.d/buildbot_worker.myinstance"
+ ewarn " rc-update add buildbot_worker.myinstance default"
+ ewarn " /etc/init.d/buildbot_worker.myinstance start"
+ ewarn "Systems using systemd can do the following:"
+ ewarn " systemctl enable buildbot_worker@myinstance.service"
+ ewarn " systemctl enable buildbot_worker.target"
+ ewarn " systemctl start buildbot_worker.target"
+ fi
+}
+
+pkg_config() {
+ local buildworker_path="/var/lib/buildbot_worker"
+ local log_path="/var/log/buildbot_worker"
+
+ einfo "This will prepare a new buildbot_worker instance in ${buildworker_path}."
+ einfo "Press Control-C to abort."
+
+ einfo "Enter the name for the new instance: "
+ read instance_name
+ [[ -z "${instance_name}" ]] && die "Invalid instance name"
+
+ local instance_path="${buildworker_path}/${instance_name}"
+ local instance_log_path="${log_path}/${instance_name}"
+
+ if [[ -e "${instance_path}" ]]; then
+ eerror "The instance with the specified name already exists:"
+ eerror "${instance_path}"
+ die "Instance already exists"
+ fi
+
+ if [[ ! -d "${instance_path}" ]]; then
+ mkdir --parents "${instance_path}" || die "Unable to create directory ${buildworker_path}"
+ fi
+ chown --recursive buildbot:buildbot "${instance_path}" || die "Setting permissions for instance failed"
+ cp "${buildworker_path}/buildbot.tac.sample" "${instance_path}/buildbot.tac" \
+ || die "Moving sample configuration failed"
+ ln --symbolic --relative "/etc/init.d/buildbot_worker" "/etc/init.d/buildbot_worker.${instance_name}" \
+ || die "Unable to create link to init file"
+
+ if [[ ! -d "${instance_log_path}" ]]; then
+ mkdir --parents "${instance_log_path}" || die "Unable to create directory ${instance_log_path}"
+ chown --recursive buildbot:buildbot "${instance_log_path}" \
+ || die "Setting permissions for instance failed"
+ fi
+ ln --symbolic --relative "${instance_log_path}/twistd.log" "${instance_path}/twistd.log" \
+ || die "Unable to create link to log file"
+
+ einfo "Successfully created a buildbot_worker instance at ${instance_path}."
+ einfo "To change the default settings edit the buildbot.tac file in this directory."
+}
diff --git a/dev-util/buildbot-worker/buildbot-worker-9999.ebuild b/dev-util/buildbot-worker/buildbot-worker-9999.ebuild
index d399f27dd277..a372eb1a754b 100644
--- a/dev-util/buildbot-worker/buildbot-worker-9999.ebuild
+++ b/dev-util/buildbot-worker/buildbot-worker-9999.ebuild
@@ -21,10 +21,10 @@ RESTRICT="!test? ( test )"
RDEPEND="
acct-user/buildbot
+ !<dev-util/buildbot-1.0.0
>=dev-python/autobahn-0.16.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-18.7.0[${PYTHON_USEDEP}]
dev-python/future[${PYTHON_USEDEP}]
- !<dev-util/buildbot-1.0.0
+ >=dev-python/twisted-18.7.0[${PYTHON_USEDEP}]
"
BDEPEND="
>=dev-python/msgpack-0.6.0[${PYTHON_USEDEP}]
diff --git a/dev-util/buildbot-worker/metadata.xml b/dev-util/buildbot-worker/metadata.xml
index 8987b1c0b79c..866f0d75fdbb 100644
--- a/dev-util/buildbot-worker/metadata.xml
+++ b/dev-util/buildbot-worker/metadata.xml
@@ -5,6 +5,10 @@
<email>dolsen@gentoo.org</email>
<name>Brian Dolbec</name>
</maintainer>
+ <maintainer type="person">
+ <email>zorry@gentoo.org</email>
+ <name>Magnus Granberg</name>
+ </maintainer>
<upstream>
<maintainer>
<email>devel@buildbot.net</email>