summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-21 03:06:01 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-21 03:23:23 -0400
commit9e84d5653bff366e36ebe6d751c069e5677ba56d (patch)
treec3deaf70555bc4fbbc34a266ba753804e589effd /dev-util/cargo-c
parentdev-ruby/dry-struct: fix tests (diff)
downloadgentoo-9e84d5653bff366e36ebe6d751c069e5677ba56d.tar.gz
gentoo-9e84d5653bff366e36ebe6d751c069e5677ba56d.tar.bz2
gentoo-9e84d5653bff366e36ebe6d751c069e5677ba56d.zip
dev-util/cargo-c: fix build with >=libgit2-1.8.0
libgit2-sys crate has a upper bound for <1.8.0 and refuses to build otherwise, but not seeing(?) any issues with it. Just a quick emergency fix, will likely be fixed next libgit2-sys version. Kept full version in the sed's path rather than a glob to force re-checking this when the crate is bumped. Alternatively could drop LIBGIT2_NO_VENDOR or set an upper bound in RDEPEND, but does not seem necessary. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util/cargo-c')
-rw-r--r--dev-util/cargo-c/cargo-c-0.9.30.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-util/cargo-c/cargo-c-0.9.30.ebuild b/dev-util/cargo-c/cargo-c-0.9.30.ebuild
index efd999171092..e17e9888da42 100644
--- a/dev-util/cargo-c/cargo-c-0.9.30.ebuild
+++ b/dev-util/cargo-c/cargo-c-0.9.30.ebuild
@@ -370,6 +370,10 @@ src_unpack() {
if [[ -n ${MY_P} ]] ; then
tar -xf "${DISTDIR}"/"${MY_P}.crate" -C "${WORKDIR}" || die
fi
+
+ # libgit2-sys unnecessarily(?) requests <libgit2-1.8.0, bump to 2 for now
+ sed -e '/range_version/s/1\.8\.0/2/' \
+ -i "${ECARGO_VENDOR}"/libgit2-sys-0.16.2+1.7.2/build.rs || die
}
src_configure() {