summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-10 10:36:01 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-10 10:37:58 +0100
commitaa3885f23b5d05a891834b9d68d08a724035328c (patch)
tree58bddbd1a7f1f18601389aa437b34600fc4afd9c /dev-util/cvise
parentdev-python/flufl-bounce: Add Python 3.8 and 3.9 (diff)
downloadgentoo-aa3885f23b5d05a891834b9d68d08a724035328c.tar.gz
gentoo-aa3885f23b5d05a891834b9d68d08a724035328c.tar.bz2
gentoo-aa3885f23b5d05a891834b9d68d08a724035328c.zip
dev-util/cvise: Remove pytest-xdist options
Closes: https://bugs.gentoo.org/753809 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/cvise')
-rw-r--r--dev-util/cvise/cvise-1.9.0.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-util/cvise/cvise-1.9.0.ebuild b/dev-util/cvise/cvise-1.9.0.ebuild
index 16f63504e0d4..8bf58ae60526 100644
--- a/dev-util/cvise/cvise-1.9.0.ebuild
+++ b/dev-util/cvise/cvise-1.9.0.ebuild
@@ -54,6 +54,11 @@ pkg_setup() {
llvm_pkg_setup
}
+src_prepare() {
+ sed -i -e 's:-n auto::' setup.cfg || die
+ cmake_src_prepare
+}
+
src_test() {
cd "${BUILD_DIR}" || die
pytest -vv || die