summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-09 14:52:34 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-09 14:52:34 +0200
commitbba8d2da9191ece48654e172f9aacf3ef8471ac6 (patch)
tree0928c54e04d06a23fc3a2139f70fc842cafad61e /dev-util/dialog
parentdev-util/byacc: add changelog (diff)
downloadgentoo-bba8d2da9191ece48654e172f9aacf3ef8471ac6.tar.gz
gentoo-bba8d2da9191ece48654e172f9aacf3ef8471ac6.tar.bz2
gentoo-bba8d2da9191ece48654e172f9aacf3ef8471ac6.zip
dev-util/dialog: add 1.3.20210324
Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-util/dialog')
-rw-r--r--dev-util/dialog/Manifest1
-rw-r--r--dev-util/dialog/dialog-1.3.20210324.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/dialog/Manifest b/dev-util/dialog/Manifest
index fc5198d6971a..949ec2796a1d 100644
--- a/dev-util/dialog/Manifest
+++ b/dev-util/dialog/Manifest
@@ -1 +1,2 @@
DIST dialog-1.3-20200327.tar.gz 547962 BLAKE2B b335d8b57d9a9f3a7e303aa3b2c64736007b66618a79c79368d9dba20a8123813cdeb7d0643bf7c6d147314963ff469b6e41d2378fe9181081fa543f0aca50f2 SHA512 c8c7ccd86fa189a2b6739320f59f127512e53f908ed257280099f8c45754da98d2095835d0c14090cd071af0ed6e8ff95f9938f5ca8027b0b7001c7fd746fe59
+DIST dialog-1.3-20210324.tgz 561235 BLAKE2B fbeae52e207def0b9ebcd9669f9321a711be82d0b6e163a94adaa21192a8fefa67255cd8b0a0121559728f4e5108ea8a90992a64d39fd0fa0f32e201de11f5a9 SHA512 6850485de5ffb4b5b702be792381b1e2c3e3e74143474b9d96f418ff755e17bd8075f1efab950cf0ca84fffb61c2373526d3607f2f1805b4056aac0ea6831069
diff --git a/dev-util/dialog/dialog-1.3.20210324.ebuild b/dev-util/dialog/dialog-1.3.20210324.ebuild
new file mode 100644
index 000000000000..49c4faca4039
--- /dev/null
+++ b/dev-util/dialog/dialog-1.3.20210324.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=${PN}-$(ver_rs 2 -)
+
+DESCRIPTION="Tool to display dialog boxes from a shell"
+HOMEPAGE="https://invisible-island.net/dialog/"
+SRC_URI="https://invisible-mirror.net/archives/dialog/${MY_P}.tgz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0/15"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="examples minimal nls static-libs unicode"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r5:=[unicode?]"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+BDEPEND="!minimal? ( sys-devel/libtool )"
+
+src_prepare() {
+ default
+ sed -i -e '/LIB_CREATE=/s:${CC}:& ${LDFLAGS}:g' configure || die
+ sed -i '/$(LIBTOOL_COMPILE)/s:$: $(LIBTOOL_OPTS):' makefile.in || die
+}
+
+src_configure() {
+ econf \
+ --disable-rpath-hack \
+ $(use_enable nls) \
+ $(use_with !minimal libtool) \
+ --with-libtool-opts=$(usex static-libs '' '-shared') \
+ --with-ncurses$(usex unicode w '')
+}
+
+src_install() {
+ use minimal && default || emake DESTDIR="${D}" install-full
+
+ use examples && dodoc -r samples
+
+ dodoc CHANGES README
+
+ find "${ED}" -name '*.la' -delete || die
+}