summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-01-15 20:25:28 +0000
committerSam James <sam@gentoo.org>2025-01-15 20:27:41 +0000
commit796f8e8da12a55b0f85238c384f77671e2f868aa (patch)
tree0eaedb3f4505536ddf29365958e075c90ad1f191 /dev-util/difftastic
parentmedia-plugins/gst-plugin-gtk4: Add missing dep on cargo-c (diff)
downloadgentoo-796f8e8da12a55b0f85238c384f77671e2f868aa.tar.gz
gentoo-796f8e8da12a55b0f85238c384f77671e2f868aa.tar.bz2
gentoo-796f8e8da12a55b0f85238c384f77671e2f868aa.zip
dev-util/difftastic: build w/ -std=gnu17
Workaround for old bundled mimalloc in mimalloc crate, see bug #944110, but updating it should be done with caution, see https://github.com/purpleprotocol/mimalloc_rust/issues/109. Closes: https://bugs.gentoo.org/944110 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/difftastic')
-rw-r--r--dev-util/difftastic/difftastic-0.61.0-r1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-util/difftastic/difftastic-0.61.0-r1.ebuild b/dev-util/difftastic/difftastic-0.61.0-r1.ebuild
index 4f9224cf6950..5c47cc323130 100644
--- a/dev-util/difftastic/difftastic-0.61.0-r1.ebuild
+++ b/dev-util/difftastic/difftastic-0.61.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2024 Gentoo Authors
+# Copyright 2024-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Autogenerated by pycargoebuild 0.13.3
@@ -151,7 +151,7 @@ CRATES="
zerocopy@0.7.32
"
-inherit cargo
+inherit cargo flag-o-matic
DESCRIPTION="A structural diff that understands syntax."
HOMEPAGE="http://difftastic.wilfred.me.uk/"
@@ -183,6 +183,14 @@ src_prepare() {
default
}
+src_configure() {
+ # Workaround for old bundled mimalloc in mimalloc crate, see
+ # bug #944110, but updating it should be done with caution, see
+ # https://github.com/purpleprotocol/mimalloc_rust/issues/109.
+ append-cflags -std=gnu17
+ cargo_src_configure
+}
+
src_install() {
cargo_src_install
dodoc -r "${DOCS[@]}"