summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-07-26 17:51:35 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-07-26 17:51:35 -0500
commit7ed3f4273043e2277e971939270356c907dc533d (patch)
tree518a88a0f4c4579675c8e9267fd85b7b247b9810 /dev-util/gertty/gertty-1.4.0.ebuild
parentapp-dicts/wordnet: new revision fixing two bugs. (diff)
downloadgentoo-7ed3f4273043e2277e971939270356c907dc533d.tar.gz
gentoo-7ed3f4273043e2277e971939270356c907dc533d.tar.bz2
gentoo-7ed3f4273043e2277e971939270356c907dc533d.zip
dev-util/gertty: bup
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-util/gertty/gertty-1.4.0.ebuild')
-rw-r--r--dev-util/gertty/gertty-1.4.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/gertty/gertty-1.4.0.ebuild b/dev-util/gertty/gertty-1.4.0.ebuild
new file mode 100644
index 000000000000..61674847f29f
--- /dev/null
+++ b/dev-util/gertty/gertty-1.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Gertty is a console-based interface to the Gerrit Code Review system."
+HOMEPAGE="https://pypi.python.org/pypi/gertty"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+ <dev-python/pbr-2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/urwid-1.2.1[${PYTHON_USEDEP}]
+ !~dev-python/urwid-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/git-python-0.3.2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.3[${PYTHON_USEDEP}]
+ <dev-python/requests-3.0.0[${PYTHON_USEDEP}]
+ dev-python/ordereddict[${PYTHON_USEDEP}]
+ >=dev-python/alembic-0.6.4[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/voluptuous-0.7[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"