summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-08-19 14:01:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-08-19 14:02:29 +0200
commitfe6839bd067a897fecdfed83cb4f90662b094ed9 (patch)
tree3e739a04f23294a05b50b0f08e7b9cbbcde3c16e /dev-util/kdevplatform
parentwww-client/chromium: dev channel bump (62.0.3188.2) (diff)
downloadgentoo-fe6839bd067a897fecdfed83cb4f90662b094ed9.tar.gz
gentoo-fe6839bd067a897fecdfed83cb4f90662b094ed9.tar.bz2
gentoo-fe6839bd067a897fecdfed83cb4f90662b094ed9.zip
dev-util/kdevplatform: Fix build, switch to KDE_TEST=true
Don't remove Qt5Test dependency and root tests dir, use the patch created by forceoptional-recursive and apply it with minor corrections. Gentoo-bug: 628288 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-util/kdevplatform')
-rw-r--r--dev-util/kdevplatform/files/kdevplatform-5.1.1-tests-optional.patch229
-rw-r--r--dev-util/kdevplatform/kdevplatform-5.1.1.ebuild13
2 files changed, 231 insertions, 11 deletions
diff --git a/dev-util/kdevplatform/files/kdevplatform-5.1.1-tests-optional.patch b/dev-util/kdevplatform/files/kdevplatform-5.1.1-tests-optional.patch
new file mode 100644
index 000000000000..385e37c38654
--- /dev/null
+++ b/dev-util/kdevplatform/files/kdevplatform-5.1.1-tests-optional.patch
@@ -0,0 +1,229 @@
+Patch autogenerated by KDE_TEST=forceoptional-recursive and edited.
+
+--- a/project/CMakeLists.txt 2017-08-19 13:39:27.223931674 +0200
++++ b/project/CMakeLists.txt 2017-08-19 13:39:27.230931474 +0200
+@@ -38,7 +38,9 @@
+ Qt5::Concurrent
+ )
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ install(FILES
+ interfaces/iprojectbuilder.h
+--- a/sublime/CMakeLists.txt 2017-08-19 13:39:27.242931131 +0200
++++ b/sublime/CMakeLists.txt 2017-08-19 13:39:27.249930930 +0200
+@@ -1,7 +1,9 @@
+ add_definitions(-DTRANSLATION_DOMAIN=\"kdevplatform\")
+
+ add_subdirectory(examples)
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(sublime_LIB_SRCS
+ area.cpp
+--- a/vcs/CMakeLists.txt 2017-08-19 13:39:27.258930673 +0200
++++ b/vcs/CMakeLists.txt 2017-08-19 13:39:27.264930501 +0200
+@@ -1,7 +1,9 @@
+ add_definitions(-DTRANSLATION_DOMAIN=\"kdevplatform\")
+
++if(BUILD_TESTING)
+ add_subdirectory(dvcs/tests)
+ add_subdirectory(models/tests)
++endif()
+
+ set(KDevPlatformVcs_UIS
+ widgets/vcscommitdialog.ui
+--- a/shell/CMakeLists.txt 2017-08-19 13:39:27.274930215 +0200
++++ b/shell/CMakeLists.txt 2017-08-19 13:39:27.281930015 +0200
+@@ -1,6 +1,8 @@
+ add_definitions(-DTRANSLATION_DOMAIN=\"kdevplatform\")
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(KDevPlatformShell_LIB_SRCS
+ workingsetcontroller.cpp
+--- a/language/CMakeLists.txt 2017-08-19 13:39:27.292929700 +0200
++++ b/language/CMakeLists.txt 2017-08-19 13:39:27.299929500 +0200
+@@ -6,11 +6,13 @@
+ check_include_file("malloc.h" HAVE_MALLOC_H)
+ check_symbol_exists(malloc_trim "malloc.h" HAVE_MALLOC_TRIM)
+
++if(BUILD_TESTING)
+ add_subdirectory(highlighting/tests)
+ add_subdirectory(duchain/tests)
+ add_subdirectory(backgroundparser/tests)
+ add_subdirectory(codegen/tests)
+ add_subdirectory(util/tests)
++endif()
+
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/language-features.h.cmake
+ ${CMAKE_CURRENT_BINARY_DIR}/language-features.h )
+--- a/language/codegen/tests/data/CMakeLists.txt 2017-08-19 13:39:27.309929214 +0200
++++ b/language/codegen/tests/data/CMakeLists.txt 2017-08-19 13:39:27.316929014 +0200
+@@ -1 +1,3 @@
++if(BUILD_TESTING)
+ add_subdirectory(kdevcodegentest)
++endif()
+--- a/outputview/CMakeLists.txt 2017-08-19 13:39:27.326928728 +0200
++++ b/outputview/CMakeLists.txt 2017-08-19 13:39:27.334928499 +0200
+@@ -31,4 +31,6 @@
+ outputexecutejob.h
+ DESTINATION ${KDE_INSTALL_INCLUDEDIR}/kdevplatform/outputview COMPONENT Devel)
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/serialization/CMakeLists.txt 2017-08-19 13:39:27.343928241 +0200
++++ b/serialization/CMakeLists.txt 2017-08-19 13:39:27.351928013 +0200
+@@ -27,4 +27,6 @@
+ DESTINATION ${KDE_INSTALL_INCLUDEDIR}/kdevplatform/serialization COMPONENT Devel
+ )
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/util/CMakeLists.txt 2017-08-19 13:39:27.360927755 +0200
++++ b/util/CMakeLists.txt 2017-08-19 13:39:27.368927526 +0200
+@@ -39,7 +39,9 @@
+
+ add_subdirectory(duchainify)
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ ki18n_wrap_ui(KDevPlatformUtil_LIB_SRCS ${KDevPlatformUtil_LIB_US})
+ kdevplatform_add_library(KDevPlatformUtil SOURCES ${KDevPlatformUtil_LIB_SRCS})
+--- a/debugger/CMakeLists.txt 2017-08-19 13:39:27.377927269 +0200
++++ b/debugger/CMakeLists.txt 2017-08-19 13:39:27.385927040 +0200
+@@ -63,4 +63,6 @@
+ DESTINATION ${KDE_INSTALL_INCLUDEDIR}/kdevplatform/debugger/framestack COMPONENT Devel
+ )
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/plugins/bazaar/CMakeLists.txt 2017-08-19 13:39:27.394926782 +0200
++++ b/plugins/bazaar/CMakeLists.txt 2017-08-19 13:39:27.402926554 +0200
+@@ -16,4 +16,6 @@
+ )
+
+ add_subdirectory(icons)
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/plugins/standardoutputview/CMakeLists.txt 2017-08-19 13:39:27.410926325 +0200
++++ b/plugins/standardoutputview/CMakeLists.txt 2017-08-19 13:39:27.418926096 +0200
+@@ -1,5 +1,7 @@
+ add_definitions(-DTRANSLATION_DOMAIN=\"kdevstandardoutputview\")
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ ########### next target ###############
+
+--- a/plugins/cvs/CMakeLists.txt 2017-08-19 13:39:27.426925867 +0200
++++ b/plugins/cvs/CMakeLists.txt 2017-08-19 13:39:27.434925638 +0200
+@@ -1,5 +1,7 @@
+ add_definitions(-DTRANSLATION_DOMAIN=\"kdevcvs\")
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+
+ ########### next target ###############
+--- a/plugins/quickopen/CMakeLists.txt 2017-08-19 13:39:27.443925381 +0200
++++ b/plugins/quickopen/CMakeLists.txt 2017-08-19 13:39:27.450925181 +0200
+@@ -1,5 +1,7 @@
+ add_definitions(-DTRANSLATION_DOMAIN=\"kdevquickopen\")
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ set(kdevquickopen_PART_SRCS
+ quickopenplugin.cpp
+--- a/plugins/genericprojectmanager/CMakeLists.txt 2017-08-19 13:39:27.458924952 +0200
++++ b/plugins/genericprojectmanager/CMakeLists.txt 2017-08-19 13:39:27.465924752 +0200
+@@ -1,6 +1,8 @@
+ add_definitions(-DTRANSLATION_DOMAIN=\"kdevgenericprojectmanager\")
+
++if(BUILD_TESTING)
+ add_subdirectory(test)
++endif()
+
+ ########### next target ###############
+
+--- a/plugins/subversion/CMakeLists.txt 2017-08-19 13:39:27.473924523 +0200
++++ b/plugins/subversion/CMakeLists.txt 2017-08-19 13:39:27.479924351 +0200
+@@ -7,7 +7,9 @@
+
+ string(REPLACE "-Wdocumentation" "" CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}")
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+ add_subdirectory(icons)
+
+ include_directories(
+--- a/plugins/grepview/CMakeLists.txt 2017-08-19 13:39:27.488924094 +0200
++++ b/plugins/grepview/CMakeLists.txt 2017-08-19 13:39:27.494923922 +0200
+@@ -39,4 +39,6 @@
+
+ ########### install files ###############
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/plugins/perforce/CMakeLists.txt 2017-08-19 13:39:27.503923665 +0200
++++ b/plugins/perforce/CMakeLists.txt 2017-08-19 13:39:27.509923493 +0200
+@@ -1,5 +1,7 @@
+ add_subdirectory(p4clientstub)
++if(BUILD_TESTING)
+ add_subdirectory(test)
++endif()
+
+ set(kdevperforce_PART_SRCS
+ perforceplugin.cpp
+--- a/plugins/filetemplates/CMakeLists.txt 2017-08-19 13:39:27.517923264 +0200
++++ b/plugins/filetemplates/CMakeLists.txt 2017-08-19 13:39:27.523923092 +0200
+@@ -89,4 +89,6 @@
+ KF5::NewStuff
+ )
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/plugins/git/CMakeLists.txt 2017-08-19 13:39:27.531922863 +0200
++++ b/plugins/git/CMakeLists.txt 2017-08-19 13:39:27.538922663 +0200
+@@ -1,6 +1,8 @@
+ add_definitions(-DTRANSLATION_DOMAIN=\"kdevgit\")
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+ add_subdirectory(icons)
+
+ set(kdevgit_PART_SRCS
+--- a/plugins/projectfilter/CMakeLists.txt 2017-08-19 13:39:27.546922435 +0200
++++ b/plugins/projectfilter/CMakeLists.txt 2017-08-19 13:39:27.552922263 +0200
+@@ -26,4 +26,6 @@
+ KDev::Interfaces
+ )
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/plugins/problemreporter/CMakeLists.txt 2017-08-19 13:39:27.560922034 +0200
++++ b/plugins/problemreporter/CMakeLists.txt 2017-08-19 13:39:27.567921834 +0200
+@@ -15,4 +15,6 @@
+ kdevplatform_add_plugin(kdevproblemreporter JSON kdevproblemreporter.json SOURCES ${kdevproblemreporter_PART_SRCS})
+ target_link_libraries(kdevproblemreporter KF5::TextEditor KF5::Parts KDev::Language KDev::Interfaces KDev::Util KDev::Project KDev::Shell)
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
diff --git a/dev-util/kdevplatform/kdevplatform-5.1.1.ebuild b/dev-util/kdevplatform/kdevplatform-5.1.1.ebuild
index a1b62d286624..de81287a2403 100644
--- a/dev-util/kdevplatform/kdevplatform-5.1.1.ebuild
+++ b/dev-util/kdevplatform/kdevplatform-5.1.1.ebuild
@@ -5,7 +5,7 @@ EAPI=6
EGIT_BRANCH="5.1"
KDEBASE="kdevelop"
-KDE_TEST="forceoptional-recursive"
+KDE_TEST="true"
VIRTUALDBUS_TEST="true"
VIRTUALX_REQUIRED="test"
inherit kde5
@@ -73,16 +73,7 @@ REQUIRED_USE="test? ( welcomepage )"
RESTRICT+=" test"
-src_prepare() {
- kde5_src_prepare
- # root tests subdirectory actually does not contain tests, installs stuff
- if ! use test; then
- sed -i -e "/add_subdirectory(tests)/ s/#DONOTCOMPILE //" \
- CMakeLists.txt || die "Failed to fix CMakeLists.txt"
- sed -i -e '1s/^/find_package(Qt5Test \$\{QT_MIN_VERSION\})\n/' \
- tests/CMakeLists.txt || die "Failed to fix tests/CMakeLists.txt"
- fi
-}
+PATCHES=( "${FILESDIR}/${P}-tests-optional.patch" )
src_configure() {
local mycmakeargs=(