summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2023-05-03 12:07:52 +0300
committerJoonas Niilola <juippis@gentoo.org>2023-05-03 12:08:51 +0300
commitaa34dd9314b1464531a93fb13a882ce12595d563 (patch)
tree44b5cdb093989ea1b2fa8e6f0d30f3dfd8ce0eff /dev-util/librnp
parentdev-libs/sexp: new package, add 0.8.3 (diff)
downloadgentoo-aa34dd9314b1464531a93fb13a882ce12595d563.tar.gz
gentoo-aa34dd9314b1464531a93fb13a882ce12595d563.tar.bz2
gentoo-aa34dd9314b1464531a93fb13a882ce12595d563.zip
dev-util/librnp: add 0.17.0
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/librnp')
-rw-r--r--dev-util/librnp/Manifest1
-rw-r--r--dev-util/librnp/files/librnp-0.17.0-dont-bundle-sexp.patch36
-rw-r--r--dev-util/librnp/librnp-0.17.0.ebuild80
3 files changed, 117 insertions, 0 deletions
diff --git a/dev-util/librnp/Manifest b/dev-util/librnp/Manifest
index 39b17e88faa6..4205de3c1ee2 100644
--- a/dev-util/librnp/Manifest
+++ b/dev-util/librnp/Manifest
@@ -1 +1,2 @@
DIST librnp-0.16.3.tar.gz 2897854 BLAKE2B 71e39e810bdbee351c8136df1d11621daccb1738db691b99244ffe5bd2ea372c3ef520ade7cd63c38510fae0f252d5a1c2ceb44db3fbffbd64dfc10612341e29 SHA512 b133fb1f9aab6e9b5caecdcf0bd9f2c67a62a98543ca1ac6a7cf4a35b7a571d53e4fa99cefc98f8253117cf0de16194db309efa03bc40fd3556f9b84cf51a942
+DIST librnp-0.17.0.tar.gz 2996461 BLAKE2B 9a6ea0452f067464ef52cef395c2969ba9912c5ed32ac6f4d860a3410965dbfbb1ad5c0d4f25489011d869222a4362a90463f521efe5af4b7c412f0ed1e4570b SHA512 0aa5262aa3be163b8a8931d6b9200ced52bb640cd7b02b50009cfb8d5fe1e664d27b2c4a0a3e534cf59d6ea42fbc1c62c970a07cadc27ab6962e0f69f996f74d
diff --git a/dev-util/librnp/files/librnp-0.17.0-dont-bundle-sexp.patch b/dev-util/librnp/files/librnp-0.17.0-dont-bundle-sexp.patch
new file mode 100644
index 000000000000..4e8b67a2f5f7
--- /dev/null
+++ b/dev-util/librnp/files/librnp-0.17.0-dont-bundle-sexp.patch
@@ -0,0 +1,36 @@
+diff -Naur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2023-05-02 11:01:48.000000000 +0300
++++ b/CMakeLists.txt 2023-05-03 11:57:06.095299932 +0300
+@@ -176,11 +176,6 @@
+ endif()
+ add_subdirectory(src/common)
+
+-set(WITH_SEXP_CLI OFF)
+-set(WITH_SEXP_TESTS OFF)
+-set(CMAKE_INSTALL_DEFAULT_COMPONENT_NAME development)
+-add_subdirectory(src/libsexp EXCLUDE_FROM_ALL)
+-
+ add_subdirectory(src/lib)
+ add_subdirectory(src/rnp)
+ add_subdirectory(src/rnpkeys)
+diff -Naur a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
+--- a/src/lib/CMakeLists.txt 2023-05-02 11:01:48.000000000 +0300
++++ b/src/lib/CMakeLists.txt 2023-05-03 10:59:25.147032470 +0300
+@@ -433,7 +433,7 @@
+ COMPONENT development
+ )
+
+- install(TARGETS librnp-static sexp
++ install(TARGETS librnp-static
+ EXPORT rnp-targets
+ ARCHIVE
+ DESTINATION "${CMAKE_INSTALL_LIBDIR}"
+@@ -441,7 +441,7 @@
+ )
+ else(BUILD_SHARED_LIBS)
+ # static libraries only
+-install(TARGETS librnp sexp
++install(TARGETS librnp
+ EXPORT rnp-targets
+ ARCHIVE
+ DESTINATION "${CMAKE_INSTALL_LIBDIR}"
diff --git a/dev-util/librnp/librnp-0.17.0.ebuild b/dev-util/librnp/librnp-0.17.0.ebuild
new file mode 100644
index 000000000000..846d10a8806d
--- /dev/null
+++ b/dev-util/librnp/librnp-0.17.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="High performance C++ OpenPGP library"
+HOMEPAGE="https://www.rnpgp.org/ https://github.com/rnpgp/rnp"
+SRC_URI="https://github.com/rnpgp/rnp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2"
+SLOT="0/0.16.1"
+KEYWORDS="~amd64"
+IUSE="+botan man test"
+
+RDEPEND="app-arch/bzip2
+ dev-libs/json-c:=
+ sys-libs/zlib
+ botan? ( dev-libs/botan:2= )
+ !botan? ( >=dev-libs/openssl-1.1.1:= )"
+DEPEND="${RDEPEND}
+ dev-libs/sexp[static-libs]
+ test? ( dev-cpp/gtest )"
+BDEPEND="man? ( dev-ruby/asciidoctor )"
+
+RESTRICT="!test? ( test )"
+S="${WORKDIR}/${P/*lib/}"
+
+PATCHES=( "${FILESDIR}"/librnp-0.17.0-dont-bundle-sexp.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test on off)
+
+ -DCRYPTO_BACKEND=$(usex botan botan openssl)
+
+ -DDOWNLOAD_GTEST=off
+
+ -DENABLE_COVERAGE=off
+ -DENABLE_DOC=$(usex man on off)
+ -DENABLE_FUZZERS=off
+ -DENABLE_SANITIZERS=off
+ )
+
+ if use botan; then
+ local mycmakeargs+=(
+ -DENABLE_AEAD=on
+ -DENABLE_BLOWFISH=on
+ -DENABLE_BRAINPOOL=on
+ -DENABLE_CAST5=on
+ -DENABLE_IDEA=on
+ -DENABLE_RIPEMD160=on
+ -DENABLE_SM2=on
+ -DENABLE_TWOFISH=on
+ )
+
+ # OpenSSL support is still not as complete as botan.
+ # https://github.com/rnpgp/rnp/issues/1877 SM2,
+ # https://github.com/openssl/openssl/issues/2046 TWOFISH (won't be implemented).
+ else
+ local mycmakeargs+=(
+ -DENABLE_AEAD=on
+ -DENABLE_BLOWFISH=on
+ -DENABLE_BRAINPOOL=on
+ -DENABLE_CAST5=on
+ -DENABLE_IDEA=on
+ -DENABLE_RIPEMD160=on
+ -DENABLE_SM2=off
+ -DENABLE_TWOFISH=off
+ )
+ fi
+
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}"/src/tests || die
+ ctest -j"${MAKEOPTS}" -R .* --output-on-failure || die
+}