summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2021-08-13 18:41:58 +0300
committerMart Raudsepp <leio@gentoo.org>2021-08-13 19:27:25 +0300
commit2656da83cf96833eb01d4e3e8663881c9f95922e (patch)
treeb475169489c032a0ae768e3816b307794428996e /dev-util/meld
parentgnome-extra/evolution-ews: bump to 3.40.4 (diff)
downloadgentoo-2656da83cf96833eb01d4e3e8663881c9f95922e.tar.gz
gentoo-2656da83cf96833eb01d4e3e8663881c9f95922e.tar.bz2
gentoo-2656da83cf96833eb01d4e3e8663881c9f95922e.zip
dev-util/meld: bump to 3.20.4
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-util/meld')
-rw-r--r--dev-util/meld/Manifest1
-rw-r--r--dev-util/meld/meld-3.20.4.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/meld/Manifest b/dev-util/meld/Manifest
index e4f885b2b55a..b22a9bf6d7cd 100644
--- a/dev-util/meld/Manifest
+++ b/dev-util/meld/Manifest
@@ -1 +1,2 @@
DIST meld-3.20.3.tar.xz 615248 BLAKE2B e60e6e9437c27cd217d39d045a5a23000b5b52e99387cfe0612c32ffb31205e467a13c8f42f478515bc8ba0d27814963649c362a7a95ac53e98f14398fd0cb3f SHA512 88052d1a59453e780a7842d2bf4d42ac5db8f5b4aa4b1ec3a931fb8d982d45fd212cfb75bb8395a2ad7b380a6e0c33d020a0562b4ffdf4afdc74d92d6d5751f0
+DIST meld-3.20.4.tar.xz 617020 BLAKE2B 70bdd7c6ecfd4dd99d1bc0b503900da65563ba74469b97590da4971d0597d4023cf74a3fd6300701d73fe7ed1b646089a5b23527e4a519313816f53c31632dad SHA512 e7b5c07e68972e7e8e4d396140fa2ee627609728533269f1bc52e9339e89a58f0949a1e8ec7b7847eec3eff5a67ea0bd5e07ad8002d2c640d173f9b0c4aa724e
diff --git a/dev-util/meld/meld-3.20.4.ebuild b/dev-util/meld/meld-3.20.4.ebuild
new file mode 100644
index 000000000000..69b74182e4ee
--- /dev/null
+++ b/dev-util/meld/meld-3.20.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="xml"
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit gnome2 distutils-r1
+
+DESCRIPTION="A graphical diff and merge tool"
+HOMEPAGE="http://meldmerge.org/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.50:2
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.12:3[cairo,${PYTHON_USEDEP}]
+ ')
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/gtk+-3.20:3[introspection]
+ >=x11-libs/gtksourceview-3.20.0:3.0[introspection]
+ >=x11-libs/pango-1.34[introspection]
+ x11-themes/hicolor-icon-theme
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ dev-util/itstool
+ sys-devel/gettext
+ $(python_gen_cond_dep 'dev-python/distro[${PYTHON_USEDEP}]')
+"
+# dev-python/distro is soft-required in BDEPEND for python3.8 and onwards,
+# but it's mainly needed for debian and derivatives - seems the fallback
+# works fine, as we aren't a special_case, just an annoying warning.
+
+python_check_deps() {
+ has_version -b "dev-python/distro[${PYTHON_USEDEP}]"
+}
+
+python_compile_all() {
+ mydistutilsargs=( --no-update-icon-cache --no-compile-schemas )
+}
+
+python_install() {
+ local mydistutilsargs=( --no-update-icon-cache --no-compile-schemas build )
+ distutils-r1_python_install
+ rm "${ED}"/usr/share/doc/meld-${PV}/{COPYING,NEWS} || die
+ rmdir "${ED}"/usr/share/doc/meld-${PV} || die
+}