summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-02-28 20:42:25 -0500
committerMatt Turner <mattst88@gentoo.org>2024-02-29 12:56:02 -0500
commit1f9d961bfe241cc1e14725c997f0e4853e0d43e0 (patch)
tree1f7acaa06edfcd4923c62a7a0949ea27b373e194 /dev-util/pkgconf
parentdev-python/redis: Bump to 5.0.2 (diff)
downloadgentoo-1f9d961bfe241cc1e14725c997f0e4853e0d43e0.tar.gz
gentoo-1f9d961bfe241cc1e14725c997f0e4853e0d43e0.tar.bz2
gentoo-1f9d961bfe241cc1e14725c997f0e4853e0d43e0.zip
dev-util/pkgconf: Add IUSE=native-symlinks
Similar to other toolchain packages. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/pkgconf')
-rw-r--r--dev-util/pkgconf/metadata.xml7
-rw-r--r--dev-util/pkgconf/pkgconf-2.1.1.ebuild6
-rw-r--r--dev-util/pkgconf/pkgconf-9999.ebuild6
3 files changed, 17 insertions, 2 deletions
diff --git a/dev-util/pkgconf/metadata.xml b/dev-util/pkgconf/metadata.xml
index 56ed879da008..0228976b1b04 100644
--- a/dev-util/pkgconf/metadata.xml
+++ b/dev-util/pkgconf/metadata.xml
@@ -11,4 +11,11 @@
<remote-id type="github">pkgconf/pkgconf</remote-id>
<remote-id type="cpe">cpe:/a:pkgconf:pkgconf</remote-id>
</upstream>
+ <use>
+ <flag name="native-symlinks">
+ Install generic symlinks like pkgconf and pkg-config.
+ If this flag is disabled, only CHOST-prefixed pkg-config
+ executables will be available to end users and ebuilds.
+ </flag>
+ </use>
</pkgmetadata>
diff --git a/dev-util/pkgconf/pkgconf-2.1.1.ebuild b/dev-util/pkgconf/pkgconf-2.1.1.ebuild
index 8651a601e51b..435eb9ff3169 100644
--- a/dev-util/pkgconf/pkgconf-2.1.1.ebuild
+++ b/dev-util/pkgconf/pkgconf-2.1.1.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="https://gitea.treehouse.systems/ariadne/pkgconf"
LICENSE="ISC"
SLOT="0/4"
-IUSE="test"
+IUSE="+native-symlinks test"
RESTRICT="!test? ( test )"
@@ -65,5 +65,9 @@ multilib_src_install() {
multilib_src_install_all() {
einstalldocs
+ if ! use native-symlinks; then
+ rm "${ED}"/usr/bin/{pkgconf,pkg-config}$(get_exeext) || die
+ fi
+
find "${ED}" -type f -name '*.la' -delete || die
}
diff --git a/dev-util/pkgconf/pkgconf-9999.ebuild b/dev-util/pkgconf/pkgconf-9999.ebuild
index c4ee052f6bee..51dd19d7b135 100644
--- a/dev-util/pkgconf/pkgconf-9999.ebuild
+++ b/dev-util/pkgconf/pkgconf-9999.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="https://gitea.treehouse.systems/ariadne/pkgconf"
LICENSE="ISC"
SLOT="0/4"
-IUSE="test"
+IUSE="+native-symlinks test"
RESTRICT="!test? ( test )"
@@ -65,5 +65,9 @@ multilib_src_install() {
multilib_src_install_all() {
einstalldocs
+ if ! use native-symlinks; then
+ rm "${ED}"/usr/bin/{pkgconf,pkg-config}$(get_exeext) || die
+ fi
+
find "${ED}" -type f -name '*.la' -delete || die
}