summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/quilt/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/quilt/files')
-rw-r--r--dev-util/quilt/files/quilt-0.48-no-graphviz.patch34
-rw-r--r--dev-util/quilt/files/quilt-0.50-no-graphviz.patch47
-rw-r--r--dev-util/quilt/files/quilt-0.63-bash-completion.patch17
-rw-r--r--dev-util/quilt/files/quilt-0.63-no-graphviz.patch43
4 files changed, 141 insertions, 0 deletions
diff --git a/dev-util/quilt/files/quilt-0.48-no-graphviz.patch b/dev-util/quilt/files/quilt-0.48-no-graphviz.patch
new file mode 100644
index 000000000000..4ae5ba09624e
--- /dev/null
+++ b/dev-util/quilt/files/quilt-0.48-no-graphviz.patch
@@ -0,0 +1,34 @@
+--- Makefile.in.orig 2009-02-24 13:49:47.000000000 -0500
++++ Makefile.in 2009-02-24 13:50:21.000000000 -0500
+@@ -82,8 +82,7 @@ QUILT := $(QUILT_IN)
+ SRC += $(QUILT_SRC:%=quilt/%)
+ DIRT += $(QUILT_IN:%=quilt/%)
+
+-SCRIPTS_IN := patchfns parse-patch inspect dependency-graph edmail \
+- remove-trailing-ws
++SCRIPTS_IN := patchfns parse-patch inspect edmail remove-trailing-ws
+
+ SCRIPTS_SRC := $(SCRIPTS_IN:%=%.in)
+ SCRIPTS := $(SCRIPTS_IN)
+--- bash_completion.orig 2009-02-24 13:49:52.000000000 -0500
++++ bash_completion 2009-02-24 13:50:46.000000000 -0500
+@@ -189,19 +189,6 @@ _quilt_completion()
+ ;;
+ esac
+ ;;
+- graph)
+- case $prev in
+- -T)
+- COMPREPLY=( $( compgen -W "ps" -- $cur ) )
+- ;;
+- --edge-labels)
+- COMPREPLY=( $( compgen -W "files" -- $cur ) )
+- ;;
+- *)
+- COMPREPLY=( $( compgen -W "-T -h --all --reduce --lines --edge-labels $(quilt applied)" -- $cur ) )
+- ;;
+- esac
+- ;;
+ grep)
+ _longopt grep
+ COMPREPLY=( ${COMPREPLY[@]:-} $( compgen -W "-h" -- $cur ) )
diff --git a/dev-util/quilt/files/quilt-0.50-no-graphviz.patch b/dev-util/quilt/files/quilt-0.50-no-graphviz.patch
new file mode 100644
index 000000000000..04e0d7d3a9a1
--- /dev/null
+++ b/dev-util/quilt/files/quilt-0.50-no-graphviz.patch
@@ -0,0 +1,47 @@
+Index: b/Makefile.in
+===================================================================
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -82,8 +82,7 @@ QUILT := $(QUILT_IN)
+ SRC += $(QUILT_SRC:%=quilt/%)
+ DIRT += $(QUILT_IN:%=quilt/%)
+
+-SCRIPTS_IN := patchfns parse-patch inspect dependency-graph edmail \
+- remove-trailing-ws
++SCRIPTS_IN := patchfns parse-patch inspect edmail remove-trailing-ws
+
+ SCRIPTS_SRC := $(SCRIPTS_IN:%=%.in)
+ SCRIPTS := $(SCRIPTS_IN)
+Index: b/bash_completion
+===================================================================
+--- a/bash_completion
++++ b/bash_completion
+@@ -95,7 +95,7 @@ _quilt_completion()
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+
+ # quilt sub commands
+- cmds='add annotate applied delete diff edit files fold fork graph \
++ cmds='add annotate applied delete diff edit files fold fork \
+ grep header import mail new next patches pop previous push refresh \
+ remove rename revert series setup snapshot top unapplied'
+
+@@ -189,19 +189,6 @@ _quilt_completion()
+ ;;
+ esac
+ ;;
+- graph)
+- case $prev in
+- -T)
+- COMPREPLY=( $( compgen -W "ps" -- $cur ) )
+- ;;
+- --edge-labels)
+- COMPREPLY=( $( compgen -W "files" -- $cur ) )
+- ;;
+- *)
+- COMPREPLY=( $( compgen -W "-T -h --all --reduce --lines --edge-labels $(quilt applied 2>/dev/null)" -- $cur ) )
+- ;;
+- esac
+- ;;
+ grep)
+ _longopt grep
+ COMPREPLY=( ${COMPREPLY[@]:-} $( compgen -W "-h" -- $cur ) )
diff --git a/dev-util/quilt/files/quilt-0.63-bash-completion.patch b/dev-util/quilt/files/quilt-0.63-bash-completion.patch
new file mode 100644
index 000000000000..c85caca5c9e1
--- /dev/null
+++ b/dev-util/quilt/files/quilt-0.63-bash-completion.patch
@@ -0,0 +1,17 @@
+--- bash_completion.orig 2014-10-21 18:15:29.549789267 -0400
++++ bash_completion 2014-10-21 18:15:38.489789221 -0400
+@@ -11,8 +11,6 @@
+ # completion to work then you must set QUILT_PC in your global environment
+ # (for example in ~/.profile) and not just in your quiltrc file.
+
+-if type quilt &> /dev/null ; then
+-
+ if ! type _expand &> /dev/null ; then
+ # This function expands tildes in pathnames
+ #
+@@ -310,5 +308,3 @@ _quilt_completion()
+ && _quilt_complete_opt="-o filenames"
+ complete -F _quilt_completion $_quilt_complete_opt quilt
+ unset -v _quilt_complete_opt
+-
+-fi
diff --git a/dev-util/quilt/files/quilt-0.63-no-graphviz.patch b/dev-util/quilt/files/quilt-0.63-no-graphviz.patch
new file mode 100644
index 000000000000..80458120f4f1
--- /dev/null
+++ b/dev-util/quilt/files/quilt-0.63-no-graphviz.patch
@@ -0,0 +1,43 @@
+--- Makefile.in.orig 2014-10-21 17:08:25.639810130 -0400
++++ Makefile.in 2014-10-21 17:09:03.269809935 -0400
+@@ -79,8 +79,7 @@ QUILT := $(QUILT_IN)
+ SRC += $(QUILT_SRC:%=quilt/%)
+ DIRT += $(QUILT_IN:%=quilt/%)
+
+-SCRIPTS_IN := patchfns inspect dependency-graph edmail \
+- remove-trailing-ws backup-files
++SCRIPTS_IN := patchfns inspect edmail remove-trailing-ws backup-files
+
+ SCRIPTS_SRC := $(SCRIPTS_IN:%=%.in)
+ SCRIPTS := $(SCRIPTS_IN)
+--- bash_completion.orig 2014-10-21 17:09:08.789809906 -0400
++++ bash_completion 2014-10-21 17:09:53.189809676 -0400
+@@ -100,7 +100,7 @@ _quilt_completion()
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+
+ # quilt sub commands
+- cmds='add annotate applied delete diff edit files fold fork graph \
++ cmds='add annotate applied delete diff edit files fold fork \
+ grep header import mail new next patches pop previous push refresh \
+ remove rename revert series setup snapshot top unapplied'
+
+@@ -194,19 +194,6 @@ _quilt_completion()
+ ;;
+ esac
+ ;;
+- graph)
+- case $prev in
+- -T)
+- COMPREPLY=( $( compgen -W "ps" -- $cur ) )
+- ;;
+- --edge-labels)
+- COMPREPLY=( $( compgen -W "files" -- $cur ) )
+- ;;
+- *)
+- COMPREPLY=( $( compgen -W "-T -h --all --reduce --lines --edge-labels $(quilt --quiltrc - applied 2>/dev/null)" -- $cur ) )
+- ;;
+- esac
+- ;;
+ grep)
+ _longopt grep
+ COMPREPLY=( ${COMPREPLY[@]:-} $( compgen -W "-h" -- $cur ) )