summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/trace-cmd/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/trace-cmd/files')
-rw-r--r--dev-util/trace-cmd/files/trace-cmd-2.5.1-makefile.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/trace-cmd/files/trace-cmd-2.5.1-makefile.patch b/dev-util/trace-cmd/files/trace-cmd-2.5.1-makefile.patch
new file mode 100644
index 000000000000..ec9fb1774a3a
--- /dev/null
+++ b/dev-util/trace-cmd/files/trace-cmd-2.5.1-makefile.patch
@@ -0,0 +1,34 @@
+diff --git a/Makefile b/Makefile
+index 186e245..9127f23 100644
+--- a/Makefile
++++ b/Makefile
+@@ -58,7 +58,7 @@ plugin_dir = $(HOME)/.trace-cmd/plugins
+ python_dir = $(HOME)/.trace-cmd/python
+ else
+ plugin_dir = $(prefix)/$(libdir)/trace-cmd/plugins
+-python_dir = $(prefix)/$(libdir)/trace-cmd/python
++python_dir ?= $(prefix)/$(libdir)/trace-cmd/python
+ PLUGIN_DIR = -DPLUGIN_DIR="$(plugin_dir)"
+ PYTHON_DIR = -DPYTHON_DIR="$(python_dir)"
+ PLUGIN_DIR_SQ = '$(subst ','\'',$(PLUGIN_DIR))'
+@@ -98,8 +98,11 @@ endif # NO_PYTHON
+ test-build = $(if $(shell sh -c 'echo "$(1)" | \
+ $(CC) -o /dev/null -c -x c - > /dev/null 2>&1 && echo y'), $2)
+
++ifndef NO_UDIS86
+ # have udis86 disassembler library?
+-udis86-flags := $(call test-build,\#include <udis86.h>,-DHAVE_UDIS86 -ludis86)
++udis86-flags := -DHAVE_UDIS86
++udis86-ldflags := -ludis86
++endif # NO_UDIS86
+
+ define BLK_TC_FLUSH_SOURCE
+ #include <linux/blktrace_api.h>
+@@ -242,6 +245,7 @@ endif
+ # Append required CFLAGS
+ override CFLAGS += $(CONFIG_FLAGS) $(INCLUDES) $(PLUGIN_DIR_SQ)
+ override CFLAGS += $(udis86-flags) $(blk-flags)
++override LDFLAGS += $(udis86-ldflags)
+
+ ifeq ($(VERBOSE),1)
+ Q =