summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2018-11-24 20:22:15 +0100
committerFabian Groffen <grobian@gentoo.org>2018-11-24 20:22:54 +0100
commitbbb155e10a68290b76f195b60558df02bd8f8cbb (patch)
tree9c72a06a45bfe74e877b173509bc4a79c64194ca /dev-util/uncrustify/uncrustify-0.68.1.ebuild
parentwww-client/chromium: beta channel bump (71.0.3578.62) (diff)
downloadgentoo-bbb155e10a68290b76f195b60558df02bd8f8cbb.tar.gz
gentoo-bbb155e10a68290b76f195b60558df02bd8f8cbb.tar.bz2
gentoo-bbb155e10a68290b76f195b60558df02bd8f8cbb.zip
dev-util/uncrustify: version bump
Signed-off-by: Fabian Groffen <grobian@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-util/uncrustify/uncrustify-0.68.1.ebuild')
-rw-r--r--dev-util/uncrustify/uncrustify-0.68.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/uncrustify/uncrustify-0.68.1.ebuild b/dev-util/uncrustify/uncrustify-0.68.1.ebuild
new file mode 100644
index 000000000000..61beeae246e6
--- /dev/null
+++ b/dev-util/uncrustify/uncrustify-0.68.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ $PV == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI=""
+ scm_eclass=git-r3
+else
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+ S=${WORKDIR}/${PN}-${P}
+fi
+
+inherit cmake-utils ${scm_eclass}
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1
+
+DESCRIPTION="C/C++/C#/D/Java/Pawn code indenter and beautifier"
+HOMEPAGE="http://uncrustify.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+python_test() {
+ cd tests
+ ${EPYTHON} run_tests.py || die "tests failed"
+}