summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2023-10-18 18:42:05 +0000
committerBenda Xu <heroxbd@gentoo.org>2023-11-27 22:34:53 +0800
commit02cb2430fcb5dbc70df96be5380228a8e47c8d80 (patch)
treef46aac85babb11b16010b7cb17d6bb3cc4703925 /dev-util
parentsci-libs/hipBLAS: add 5.7.1 (diff)
downloadgentoo-02cb2430fcb5dbc70df96be5380228a8e47c8d80.tar.gz
gentoo-02cb2430fcb5dbc70df96be5380228a8e47c8d80.tar.bz2
gentoo-02cb2430fcb5dbc70df96be5380228a8e47c8d80.zip
dev-util/Tensile: add 5.7.1
increase LLVM_MAX_SLOT to 17 Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/Tensile/Manifest1
-rw-r--r--dev-util/Tensile/Tensile-5.7.1-r1.ebuild132
-rw-r--r--dev-util/Tensile/files/Tensile-5.7.1-expand-isa-compatibility.patch49
-rw-r--r--dev-util/Tensile/files/Tensile-5.7.1-gentoopath.patch57
4 files changed, 239 insertions, 0 deletions
diff --git a/dev-util/Tensile/Manifest b/dev-util/Tensile/Manifest
index 643f4fe5816c..4d93ffa204a1 100644
--- a/dev-util/Tensile/Manifest
+++ b/dev-util/Tensile/Manifest
@@ -1,3 +1,4 @@
DIST Tensile-5.0.2-PR1419.patch.gz 43754 BLAKE2B 3b1d7333ed0115f77816806e7735e25d897dbae3f7a40ece61d655c8f016d9d1c804b586b4e0e75661e20c517f5937a61d5ead25a545f0ce2e4a178bcbb3e7be SHA512 0154d8e14d335f4ecd86e5db335289f8662cede7e5d4b93bf6c56d8e48c1d7d0457271c078c9abbbca1f4aa91f028f6ce6a89efb783ba0207d0f39fd5de8a42c
DIST rocm-Tensile-5.1.3.tar.gz 14357517 BLAKE2B 7c5881cc2b1d25db39f54a99f9f0a08395a5f7a58deebe74d9868e8f7044db5ae2f3907196adf16dc6abeba0f1f47f5cce5c8900891276daff8e4ad614cf3b94 SHA512 4405cb6de65c1da1fd93910fc901402a24e996ff04eccadf483c25d8eb518e03ea9bbf00e372dd5fe377696e71c39355603095f3c5fc1e26d311ed15d8e3b734
DIST rocm-Tensile-5.4.2.tar.gz 14413805 BLAKE2B ca1c13785164439f6fe83f16b36b7a0b06a63b70b9f0741d77b0fff98f38d1e1c7e9a54ef61897e6eb0a4eaf52ec9e5f14f42a7e6fd657f26306afa3de0c74a2 SHA512 d99736a202c7353979e732941199b4b20e53ff2b6c19a7175609440a840aa5624bc53a8013c435f31ac37933527771521ff02137c1c8fd53c5317eca8533be80
+DIST rocm-Tensile-5.7.1.tar.gz 12396002 BLAKE2B ec2c2bc3f07fe22abd800b642c998ea80b9e4e2d0d28c4763d574dbd2fcb14c735223ddc7571d4ab3a48f0bd819cc835c16df9882049c5bf56f25ef729e6d654 SHA512 8f356f36cfec74ee9b000d1180cf52077dc5c595e5c5a40792fc3eb13f3139980c7440f9bc912218f946cf8137e2481d23fe39f110511c1bb55fe85a933ffd36
diff --git a/dev-util/Tensile/Tensile-5.7.1-r1.ebuild b/dev-util/Tensile/Tensile-5.7.1-r1.ebuild
new file mode 100644
index 000000000000..709189734d4a
--- /dev/null
+++ b/dev-util/Tensile/Tensile-5.7.1-r1.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+ROCM_VERSION=${PV}
+inherit cmake distutils-r1 llvm prefix rocm
+
+LLVM_MAX_SLOT=17
+
+DESCRIPTION="Stretching GPU performance for GEMMs and tensor contractions"
+HOMEPAGE="https://github.com/ROCmSoftwarePlatform/Tensile"
+SRC_URI="https://github.com/ROCmSoftwarePlatform/Tensile/archive/rocm-${PV}.tar.gz -> rocm-Tensile-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-rocm-${PV}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="client test"
+REQUIRED_USE="client? ( ${ROCM_REQUIRED_USE} )"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-cpp/msgpack-cxx-6.0.0
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-util/hip
+ >=dev-util/rocm-smi-4.3.0
+ sys-devel/clang:${LLVM_MAX_SLOT}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-change-cmake-name-for-msgpack-cxx-6-release.patch
+ "${FILESDIR}"/${PN}-4.3.0-output-commands.patch
+ "${FILESDIR}"/${PN}-5.4.2-fix-arch-parse.patch
+ "${FILESDIR}"/${PN}-5.4.2-use-ninja.patch
+ "${FILESDIR}"/${PN}-5.7.1-expand-isa-compatibility.patch
+)
+
+CMAKE_USE_DIR="${S}/${PN}/Source"
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -e "s,\@LLVM_PATH\@,$(get_llvm_prefix ${LLVM_MAX_SLOT}),g" \
+ "${FILESDIR}"/${PN}-5.7.1-gentoopath.patch > "${S}"/gentoopath.patch || die
+ eapply $(prefixify_ro "${S}"/gentoopath.patch)
+
+ pushd ${PN} || die
+
+ sed -e "/ROCM_SMI_ROOT/s,lib,$(get_libdir)," \
+ -i Source/cmake/FindROCmSMI.cmake || die
+ sed -r -e "/TENSILE_USE_LLVM/s/ON/OFF/" \
+ -i Source/CMakeLists.txt || die
+
+ # ${Tensile_ROOT}/bin does not exists; call command directly
+ sed -e "s,\${Tensile_ROOT}/bin/,,g" -i cmake/TensileConfig.cmake || die
+
+ local Tensile_share_dir="\"${EPREFIX}/usr/share/${PN}\""
+ sed -e "/HipClangVersion/s/0.0.0/$(hipconfig -v)/" -i Common.py || die
+
+ sed -e "s,os.path.dirname(os.path.realpath(__file__)),${Tensile_share_dir},g" \
+ -i ReplacementKernels.py Common.py ${PN}.py || die
+
+ sed -e "s|os\.path\.dirname.*$|\"${EPREFIX}/usr/share/Tensile/Source\", end='')|" -i __init__.py || die
+
+ popd || die
+
+ sed -e "/package_data/d" -e "/data_files/d" -i setup.py || die
+ use client && PATCHES= cmake_src_prepare # do not apply patches again in cmake_src_prepare
+}
+
+src_configure() {
+ distutils-r1_src_configure
+ if use client; then
+ local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=ON
+ -DTENSILE_USE_MSGPACK=ON
+ -DTENSILE_USE_LLVM=ON
+ -DTensile_LIBRARY_FORMAT=msgpack
+ -DAMDGPU_TARGETS="$(get_amdgpu_flags)"
+ )
+ CXX=hipcc cmake_src_configure
+ fi
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ use client && cmake_src_compile
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ python_moduleinto Tensile
+ pushd Tensile || die
+ python_domodule Components
+ python_newexe Utilities/merge.py ${PN}-merge
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ pushd ${PN} || die
+ insinto /usr/share/${PN}
+ doins -r Configs Perf ReplacementKernels-cov3 Source CustomKernels
+ insinto /usr/$(get_libdir)/cmake/${PN}
+ doins cmake/*.cmake
+
+ if use client; then
+ pushd "${BUILD_DIR}" || die
+ dobin client/tensile_client
+ fi
+}
+
+# Test suite fails to start without this
+python_test() {
+ export ROCM_PATH="${EPREFIX}/usr"
+ epytest
+}
diff --git a/dev-util/Tensile/files/Tensile-5.7.1-expand-isa-compatibility.patch b/dev-util/Tensile/files/Tensile-5.7.1-expand-isa-compatibility.patch
new file mode 100644
index 000000000000..ebfc537c5c4d
--- /dev/null
+++ b/dev-util/Tensile/files/Tensile-5.7.1-expand-isa-compatibility.patch
@@ -0,0 +1,49 @@
+Allow Tensile to load the compatible kernels when running on
+architectures compatible with those ISAs.
+
+Based on patch from Cordell Bloor <cgmb@slerp.xyz>
+https://salsa.debian.org/rocm-team/rocblas/-/blob/master/debian/patches/0012-expand-isa-compatibility.patch
+
+--- a/Tensile/Source/lib/source/hip/HipHardware.cpp
++++ b/Tensile/Source/lib/source/hip/HipHardware.cpp
+@@ -24,6 +24,8 @@
+ *
+ *******************************************************************************/
+
++#include <cstring>
++
+ #include <Tensile/AMDGPU.hpp>
+ #include <Tensile/hip/HipHardware.hpp>
+ #include <Tensile/hip/HipUtils.hpp>
+@@ -56,6 +58,31 @@ namespace Tensile
+ {
+ hipDeviceProp_t prop;
+ HIP_CHECK_EXC(hipGetDeviceProperties(&prop, deviceId));
++ // coerce to compatible arch
++ switch(prop.gcnArch)
++ {
++ case 902:
++ case 909:
++ case 912:
++ prop.gcnArch = 900;
++ std::strcpy(prop.gcnArchName, "gfx900");
++ break;
++ case 1011:
++ case 1012:
++ case 1013:
++ prop.gcnArch = 1010;
++ std::strcpy(prop.gcnArchName, "gfx1010");
++ break;
++ case 1031:
++ case 1032:
++ case 1033:
++ case 1034:
++ case 1035:
++ case 1036:
++ prop.gcnArch = 1030;
++ std::strcpy(prop.gcnArchName, "gfx1030");
++ break;
++ }
+ #if HIP_VERSION >= 50220730
+ int hip_version;
+ HIP_CHECK_EXC(hipRuntimeGetVersion(&hip_version));
diff --git a/dev-util/Tensile/files/Tensile-5.7.1-gentoopath.patch b/dev-util/Tensile/files/Tensile-5.7.1-gentoopath.patch
new file mode 100644
index 000000000000..c8bc360cc39b
--- /dev/null
+++ b/dev-util/Tensile/files/Tensile-5.7.1-gentoopath.patch
@@ -0,0 +1,57 @@
+Fix incorrect path in scripts and CMakeLists, in order to build tensile_client
+
+--- a/HostLibraryTests/CMakeLists.txt
++++ b/HostLibraryTests/CMakeLists.txt
+@@ -139,7 +139,7 @@ set(test_sources ${test_sources}
+ )
+
+ if(TENSILE_USE_LLVM)
+- find_package(LLVM REQUIRED CONFIG)
++ find_package(LLVM PATHS @LLVM_PATH@ REQUIRED CONFIG)
+
+ set(test_sources ${test_sources}
+ ContractionLibraryLoading_test.cpp
+--- a/Tensile/ClientWriter.py
++++ b/Tensile/ClientWriter.py
+@@ -176,7 +176,7 @@ def runClient(libraryLogicPath, forBenchmark, enableTileSelection, configPaths=N
+ def getBuildClientLibraryScript(buildPath, libraryLogicPath):
+ callCreateLibraryCmd = ["python"] if os.name == "nt" else []
+
+- callCreateLibraryCmd += [os.path.join(globalParameters["ScriptPath"] , "bin", "TensileCreateLibrary")]
++ callCreateLibraryCmd += ["TensileCreateLibrary"]
+
+ if globalParameters["MergeFiles"]:
+ callCreateLibraryCmd += ["--merge-files"]
+--- a/Tensile/Common.py
++++ b/Tensile/Common.py
+@@ -2108,7 +2108,7 @@ def assignGlobalParameters( config ):
+ else:
+ print2(" %24s: %8s (unspecified)" % (key, defaultValue))
+
+- globalParameters["ROCmPath"] = "/opt/rocm"
++ globalParameters["ROCmPath"] = "@GENTOO_PORTAGE_EPREFIX@/usr"
+ if "ROCM_PATH" in os.environ:
+ globalParameters["ROCmPath"] = os.environ.get("ROCM_PATH")
+ if "TENSILE_ROCM_PATH" in os.environ:
+--- a/Tensile/GenerateSummations.py
++++ b/Tensile/GenerateSummations.py
+@@ -59,7 +59,7 @@ def createLibraryForBenchmark(logicPath, libraryPath, currentPath):
+ Selection.
+ """
+
+- pythonExePath = os.path.join(os.path.dirname(os.path.realpath(__file__)), "bin", "TensileCreateLibrary")
++ pythonExePath = "TensileCreateLibrary"
+ args = [pythonExePath, \
+ "--merge-files", "--new-client-only", "--no-short-file-names", "--no-library-print-debug", \
+ "--architecture=all", "--cxx-compiler=hipcc", "--library-format=yaml", \
+--- a/Tensile/Source/lib/CMakeLists.txt
++++ b/Tensile/Source/lib/CMakeLists.txt
+@@ -52,7 +52,7 @@ set(tensile_sources ${tensile_sources}
+ )
+
+ if(TENSILE_USE_LLVM)
+- find_package(LLVM REQUIRED CONFIG)
++ find_package(LLVM PATHS @LLVM_PATH@ REQUIRED CONFIG)
+
+ set(tensile_sources ${tensile_sources}
+ source/llvm/YAML.cpp